WordPress plugin · maxbuttons
Is MaxButtons safe?
Safe on 9.8.6 or newer.
The current version, 9.8.6, is past every affected range on record (13 of 14 records list one; 1 doesn’t, so check it below). Keep it updated and you’re clear of them.
- Flaws on record
- 14
- High or critical
- 0
- Exploited
- none
- Current version
- 9.8.6
- Last updated
- Sep 30, 2026
- Active installs
- 70,000+
Every recorded flaw
- Jun 27, 2026MaxButtons – Create buttons: Reflected Cross-Site ScriptingCVE-2026-13245 · affects up to 9.8.5 · reported by WordfenceMedium 6.1
- Apr 17, 2025MaxButtons: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-39444 · affects up to 9.8.3 · reported by PatchstackMedium 5.9
- Dec 20, 2024WordPress Button Plugin MaxButtons: Does not sanitise and escape some of its settingsCVE-2024-8968 · fixed in 9.8.1 · reported by WPScanMedium 4.7
- Dec 20, 2024WordPress Button Plugin MaxButtons: Does not sanitise and escape some of its settingsCVE-2024-10555 · fixed in 9.8.1 · reported by WPScanMedium 4.8
- Aug 24, 2024WordPress Button Plugin MaxButtons: Information exposureCVE-2024-6499 · affects up to 9.7.8 · reported by WordfenceMedium 5.3
- Jul 13, 2024WordPress Button Plugin MaxButtons: Does not sanitise and escape some parametersCVE-2024-3026 · fixed in 9.7.8 · reported by WPScanMedium 5.4
- Feb 5, 2024WordPress Button Plugin MaxButtons: Stored Cross-Site ScriptingCVE-2023-7029 · affects up to 9.7.6 · fixed in 9.7.6 · reported by WordfenceMedium 6.4
- Jan 8, 2024WordPress Button Plugin MaxButtons: Stored Cross-Site ScriptingCVE-2023-6594 · affects up to 9.7.4 · reported by WordfenceMedium 4.4
- Jul 25, 2023Auth.CVE-2023-36503 · affects up to 9.5.3 · reported by PatchstackMedium 6.5
- Mar 5, 2023A vulnerability was found in MaxButtons Plugin up to 1.26.0 on WordPress and classified as problematic.CVE-2014-125092 · affects up to 1.26.0 · reported by VulDBLow 3.5
- Sep 23, 2022Authenticated (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Max Foundry Button Plugin MaxButtons plugin <= 9.2 at WordPressCVE-2022-38703 · affects up to 9.2 · reported by PatchstackLow 3.4
- Aug 22, 2022Multiple Cross-Site Request Forgery (CSRF) vulnerabilities in Max Foundry MaxButtons plugin <= 9.2 at WordPress.CVE-2022-36346 · affects up to 9.2 · reported by PatchstackMedium 4.3
- May 22, 2017MaxButtons prior to version 6.19 and MaxButtons Pro prior to version 6.19: Cross-site scriptingCVE-2017-2169 · reported by vultures@jpcert.or.jp1.4% oddsMedium 6.1
- Oct 16, 2014Cross-site scripting (XSS) vulnerability in the Max Foundry MaxButtons plugin before 1.26.1 for WordPress allows remote attackers to inject arbitrary web scriptCVE-2014-7181 · fixed in 1.26.1 · reported by MITRE2.1% oddsMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.