WordPress plugin · mail-subscribe-list
Is Mail Subscribe List safe?
A flaw affects the current version.
The newest release on wordpress.org, 2.1.10, is inside the affected range of CVE-2025-58018, so there may be no fix yet. Check the changelog; if it doesn’t mention the fix, deactivate it until it does.
- Flaws on record
- 4
- High or critical
- 0
- Exploited
- none
- Current version
- 2.1.10
- Last updated
- Aug 8, 2023
- Active installs
- 3,000+
Every recorded flaw
- Sep 22, 2025Mail Subscribe List: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-58018 · affects up to 2.1.10 · reported by PatchstackMedium 6.5
- May 16, 2023Auth.CVE-2023-23657 · affects up to 2.1.9 · reported by PatchstackMedium 6.5
- May 1, 2023A vulnerability, which was classified as problematic, has been found in Mail Subscribe List Plugin up to 2.0.10 on WordPress.CVE-2013-10026 · affects up to 2.0.10 · reported by VulDBLow 3.5
- Jun 20, 2022Mail Subscribe List: Does not have CSRF check in placeCVE-2022-1603 · fixed in 2.1.4 · reported by WPScanMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.