WordPress plugin · litespeed-cache
Is LiteSpeed Cache safe?
Safe on 7.9.2 or newer.
The current version, 7.9.2, is past every affected range on record (27 of 27 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 27
- High or critical
- 12
- Exploited
- none
- Current version
- 7.9.2
- Last updated
- Oct 20, 2026
- Active installs
- 7,000,000+
Every recorded flaw
- Oct 24, 2026LiteSpeed Cache: Insertion of Sensitive Information Into Sent DataCVE-2026-114190 · affects up to 7.9 · reported by PatchstackMedium 5.9
- Oct 23, 2026LiteSpeed Cache: Does not perform a capability check on its admin-notice dismissal handlerCVE-2026-113501 · fixed in 7.9.2 · reported by WPScanLow 3.1
- Oct 23, 2026LiteSpeed Cache: Does not limit one of its HTML optimization routines to stylesheet contentCVE-2026-113500 · fixed in 7.9.2 · reported by WPScanHigh 7.5
- Oct 23, 2026LiteSpeed Cache: Does not restrict one of its HTML rewriting routines to stylesheet contentCVE-2026-113499 · fixed in 7.9.2 · reported by WPScanHigh 7.5
- Sep 19, 2026LiteSpeed Cache: Reflected Cross-Site ScriptingCVE-2026-76579 · affects up to 7.9 · reported by WordfenceMedium 4.7
- Sep 3, 2026Unauthenticated Server Side Request Forgery (SSRF) in LiteSpeed Cache <= 7.9 versions.CVE-2026-84761 · affects up to 7.9 · reported by PatchstackHigh 7.2
- Aug 28, 2026LiteSpeed Cache: Stored Cross-Site ScriptingCVE-2026-3129 · affects up to 7.7 · reported by WordfenceMedium 6.4
- Aug 28, 2026LiteSpeed Cache: Stored Cross-Site ScriptingCVE-2026-18978 · affects up to 7.8.1 · reported by WordfenceHigh 7.2
- May 27, 2026LiteSpeed Cache: Stored Cross-Site ScriptingCVE-2026-3375 · affects up to 7.7 · reported by WordfenceHigh 7.2
- Feb 20, 2026LiteSpeed Cache: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-51915 · affects up to 6.5.2 · reported by PatchstackMedium 6.5
- Oct 29, 2025LiteSpeed Cache: Reflected Cross-Site ScriptingCVE-2025-12450 · affects up to 7.5.0.1 · reported by WordfenceMedium 6.1
- Sep 9, 2025LiteSpeed Cache: Server-Side Request Forgery (SSRF)CVE-2025-47437 · affects up to 7.0.1 · reported by PatchstackMedium 6.4
- Oct 29, 2024LiteSpeed Cache: Incorrect Privilege AssignmentCVE-2024-50550 · affects up to 6.5.1 · reported by PatchstackHigh 8.1
- Oct 20, 2024LiteSpeed Cache: Insufficiently Protected CredentialsCVE-2024-44000 · fixed in 6.5.0.1 · reported by Patchstack82% oddsCritical 9.8
- Oct 16, 2024LiteSpeed Cache: Relative Path TraversalCVE-2024-47637 · affects up to 6.4.1 · reported by PatchstackHigh 8.8
- Oct 5, 2024LiteSpeed Cache: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-47374 · affects up to 6.5.0.2 · reported by Patchstack1.4% oddsHigh 7.1
- Oct 5, 2024LiteSpeed Cache: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-47373 · affects up to 6.5.0.2 · reported by PatchstackMedium 6.5
- Sep 25, 2024LiteSpeed Cache: Stored Cross-Site ScriptingCVE-2024-9169 · affects up to 6.4.1 · reported by WordfenceMedium 5.5
- Aug 21, 2024LiteSpeed Cache: Incorrect Privilege AssignmentCVE-2024-28000 · affects up to 6.3.0.1 · reported by Patchstack68% oddsCritical 9.8
- Jul 24, 2024LiteSpeed Cache: Cross-Site Request ForgeryCVE-2024-3246 · affects up to 6.2.0.1 · reported by WordfenceMedium 6.1
- Apr 16, 2024LiteSpeed Cache: Missing AuthorizationCVE-2023-45000 · affects up to 5.7 · reported by PatchstackHigh 8.2
- Apr 16, 2024LiteSpeed Cache: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2023-40000 · affects up to 5.7 · reported by Patchstack55% oddsHigh 8.3
- Jan 11, 2024LiteSpeed Cache: Stored Cross-Site ScriptingCVE-2023-4372 · affects up to 5.6 · reported by Wordfence20% oddsMedium 6.4
- May 25, 2023Cross-Site Request Forgery (CSRF) vulnerability in LiteSpeed Technologies LiteSpeed Cache plugin <= 5.3 versions.CVE-2022-46800 · affects up to 5.3 · reported by PatchstackMedium 5.4
- Jan 3, 2022LiteSpeed Cache: Does not properly verify that requests are coming from QUICCVE-2021-24964 · fixed in 4.4.4 · reported by WPScan1.2% oddsMedium 6.1
- Jan 3, 2022LiteSpeed Cache: Does not escape the qc_res parameter before outputting it back in the JS code of an admin pageCVE-2021-24963 · fixed in 4.4.4 · reported by WPScanMedium 4.8
- Dec 25, 2020A cross-site scripting (XSS) vulnerability in the LiteSpeed Cache plugin before 3.6.1 for WordPress can be exploited via the Server IP setting.CVE-2020-29172 · fixed in 3.6.1 · reported by MITREMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.