WordPress plugin · js-jobs
Is JS Job Manager safe?
7 flaws affect the current version.
The newest release on wordpress.org, 2.0.2, is inside the affected range of 7 records, so there may be no fix yet. Check the changelog; if it doesn’t mention the fix, deactivate it until it does.
- Flaws on record
- 11
- High or critical
- 5
- Exploited
- none
- Current version
- 2.0.2
- Last updated
- Nov 22, 2025
- Active installs
- 100+
Every recorded flaw
- Sep 22, 2025JS Job Manager: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-58234 · affects up to 2.0.2 · reported by PatchstackMedium 6.5
- Apr 17, 2025JS Job Manager: Unrestricted Upload of File with Dangerous TypeCVE-2025-32660 · affects up to 2.0.2 · reported by PatchstackCritical 10
- Apr 17, 2025JS Job Manager: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2025-32626 · affects up to 2.0.2 · reported by PatchstackCritical 9.3
- Apr 11, 2025JS Job Manager: Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')CVE-2025-32627 · affects up to 2.0.2 · reported by PatchstackHigh 8.1
- Apr 4, 2025JS Job Manager: Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')CVE-2025-32146 · affects up to 2.0.2 · reported by PatchstackHigh 8.8
- Apr 1, 2025JS Job Manager: Missing AuthorizationCVE-2025-31868 · affects up to 2.0.2 · reported by PatchstackMedium 5.3
- Apr 1, 2025JS Job Manager: Authorization Bypass Through User-Controlled KeyCVE-2025-31867 · affects up to 2.0.2 · reported by PatchstackMedium 5.4
- Dec 9, 2024JS Job Manager: Missing AuthorizationCVE-2023-28689 · affects up to 2.0.0 · reported by PatchstackMedium 6.5
- Nov 9, 2023Cross-Site Request Forgery (CSRF) vulnerability in JoomSky JS Job Manager plugin <= 2.0.0 versions.CVE-2023-31087 · fixed in 2.0.1 · reported by PatchstackMedium 5.4
- Jun 16, 2023Auth.CVE-2023-25963 · affects up to 2.0.0 · reported by PatchstackMedium 5.9
- Aug 16, 2019The js-jobs plugin before 1.0.7 for WordPress has CSRF.CVE-2018-20974 · fixed in 1.0.7 · reported by MITREHigh 8.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.