WordPress plugin · job-postings
Is Job Postings safe?
Safe on 2.8.3 or newer.
The current version, 2.8.3, is past every affected range on record (13 of 13 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 13
- High or critical
- 3
- Exploited
- none
- Current version
- 2.8.3
- Last updated
- Oct 15, 2026
- Active installs
- 10,000+
Every recorded flaw
- Oct 6, 2026Contributor Arbitrary File Deletion in Jobs for WordPress <= 2.8.2 versions.CVE-2026-39752 · affects up to 2.8.2 · reported by PatchstackHigh 7.7
- Sep 15, 2026Job Postings: Stored Cross-Site ScriptingCVE-2026-18063 · affects up to 2.8.1 · reported by WordfenceMedium 6.4
- Mar 25, 2026Jobs for: Missing AuthorizationCVE-2026-23806 · affects up to 2.8 · reported by PatchstackHigh 7.5
- Dec 24, 2025Jobs for: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-68597 · affects up to 2.8.1 · reported by PatchstackMedium 6.5
- Jun 20, 2025Jobs for: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-50050 · affects up to 2.7.14 · reported by PatchstackMedium 6.5
- Mar 26, 2025Jobs for: Directory TraversalCVE-2025-1310 · affects up to 2.7.11 · reported by WordfenceMedium 6.5
- Mar 25, 2025Job Postings: Does not sanitise and escape some of its settingsCVE-2024-10105 · fixed in 2.7.11 · reported by WPScanMedium 5.9
- Nov 15, 2024Jobs for: Does not sanitise and escape some of its Job settingsCVE-2024-10104 · fixed in 2.7.8 · reported by WPScanMedium 5.9
- Apr 18, 2024Jobs for: Reflected Cross-Site ScriptingCVE-2024-2833 · affects up to 2.7.5 · reported by WordfenceMedium 6.1
- Apr 15, 2024Jobs for: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-32149 · affects up to 2.7.5 · reported by PatchstackHigh 7.1
- Mar 18, 2024Jobs for: Does not sanitise and escape some parametersCVE-2024-0820 · fixed in 2.7.4 · reported by WPScanMedium 5.4
- May 3, 2023Auth.CVE-2023-26017 · fixed in 2.5.11 · reported by PatchstackMedium 5.9
- Apr 23, 2023Auth.CVE-2022-44743 · fixed in 2.6.0 · reported by PatchstackMedium 6.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.