WordPress plugin · jeg-elementor-kit
Is Jeg Kit for Elementor safe?
Safe on 3.2.23 or newer.
The current version, 3.2.23, is past every affected range on record (26 of 26 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 26
- High or critical
- 3
- Exploited
- none
- Current version
- 3.2.23
- Last updated
- Oct 21, 2026
- Active installs
- 300,000+
Every recorded flaw
- Oct 14, 2026JNews - Jeg Elementor Kit: Unauthorized access of dataCVE-2026-103907 · affects up to 3.2.19 · reported by WordfenceMedium 6.5
- Oct 2, 2026Jeg Kit for Elementor – Powerful Addons for Elementor, Widgets & Templates for: Stored Cross-Site ScriptingCVE-2026-100180 · affects up to 3.2.19 · reported by WordfenceMedium 5.4
- Sep 18, 2026Jeg Kit for Elementor – Powerful Addons for Elementor, Widgets & Templates for: Stored Cross-Site ScriptingCVE-2026-18405 · affects up to 3.2.16 · reported by WordfenceHigh 7.2
- Aug 6, 2026Author PHP Object Injection in Jeg Kit for Elementor <= 3.2.10 versions.CVE-2026-65549 · affects up to 3.2.10 · reported by PatchstackHigh 7.2
- Aug 1, 2026Jeg Kit for Elementor: Sensitive Information ExposureCVE-2026-2916 · affects up to 3.1.1 · reported by WordfenceMedium 4.3
- Jul 10, 2026Jeg Kit for Elementor – Powerful Addons for Elementor, Widgets & Templates for: Stored Cross-Site ScriptingCVE-2026-13710 · affects up to 3.2.6 · reported by WordfenceMedium 6.4
- May 2, 2026Jeg Kit for Elementor – Powerful Addons for Elementor, Widgets & Templates for: Stored Cross-Site ScriptingCVE-2026-6916 · affects up to 3.1.0 · reported by WordfenceMedium 6.4
- Jan 7, 2026Jeg Elementor Kit: Stored Cross-Site ScriptingCVE-2025-14275 · affects up to 3.0.1 · reported by WordfenceMedium 6.4
- Oct 24, 2025Jeg Kit for Elementor: Does not sanitize SVG file contentsCVE-2025-9978 · fixed in 2.7.0 · reported by WPScanMedium 6.8
- May 10, 2025Jeg Elementor Kit: Stored Cross-Site ScriptingCVE-2025-2944 · affects up to 2.6.12 · reported by WordfenceMedium 6.4
- Feb 27, 2025Jeg Elementor Kit: Sensitive Information ExposureCVE-2024-13217 · affects up to 2.6.11 · reported by WordfenceMedium 4.3
- Nov 26, 2024Jeg Elementor Kit: Sensitive Information ExposureCVE-2024-8899 · affects up to 2.6.9 · reported by WordfenceMedium 4.3
- Nov 26, 2024Jeg Elementor Kit: Stored Cross-Site ScriptingCVE-2024-10308 · affects up to 2.6.9 · reported by WordfenceMedium 6.4
- Oct 5, 2024Jeg Elementor Kit: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-47390 · affects up to 2.6.8 · reported by PatchstackMedium 6.5
- Aug 27, 2024Jeg Elementor Kit: Stored Cross-Site ScriptingCVE-2024-6804 · affects up to 2.6.7 · reported by WordfenceMedium 6.4
- Jun 14, 2024Jeg Elementor Kit: Stored Cross-Site ScriptingCVE-2024-4479 · affects up to 2.6.5 · reported by WordfenceMedium 6.4
- May 2, 2024Jeg Elementor Kit: Stored Cross-Site ScriptingCVE-2024-3819 · affects up to 2.6.4 · reported by WordfenceMedium 6.4
- May 2, 2024Jeg Elementor Kit: Stored Cross-Site ScriptingCVE-2024-3161 · affects up to 2.6.4 · reported by WordfenceMedium 6.4
- May 1, 2024Jeg Elementor Kit: Stored Cross-Site ScriptingCVE-2024-0334 · affects up to 2.6.4 · reported by WordfenceMedium 6.4
- Apr 24, 2024Jeg Elementor Kit: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-32721 · affects up to 2.6.3 · reported by PatchstackMedium 6.5
- Apr 2, 2024Jeg Elementor Kit: Stored Cross-Site ScriptingCVE-2024-3162 · affects up to 2.6.3 · reported by WordfenceMedium 6.4
- Apr 2, 2024Jeg Elementor Kit: Stored Cross-Site ScriptingCVE-2024-1327 · affects up to 2.6.3 · reported by WordfenceMedium 6.4
- Mar 20, 2024Jeg Elementor Kit: Stored Cross-Site ScriptingCVE-2024-1326 · affects up to 2.6.2 · reported by WordfenceMedium 6.4
- Mar 19, 2024Jeg Elementor Kit: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-29101 · affects up to 2.6.2 · reported by PatchstackMedium 6.5
- Dec 22, 2022Jeg Elementor Kit: Authorization bypass in various functions used to update the plugin settingsCVE-2022-3805 · affects up to 2.5.6 · reported by Wordfence1.7% oddsHigh 8.6
- Dec 22, 2022Jeg Elementor Kit: Authorization bypass in various AJAX actionsCVE-2022-3794 · affects up to 2.5.6 · reported by WordfenceMedium 5.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.