WordPress plugin · header-footer-elementor
Is Ultimate Addons for Elementor safe?
Safe on 2.9.5 or newer.
The current version, 2.9.5, is past every affected range on record (14 of 14 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 14
- High or critical
- 0
- Exploited
- none
- Current version
- 2.9.5
- Last updated
- Sep 25, 2026
- Active installs
- 2,000,000+
Every recorded flaw
- Jul 22, 2026Ultimate Addons for Elementor: Stored Cross-Site ScriptingCVE-2026-15787 · affects up to 2.9.1 · reported by WordfenceMedium 6.4
- Oct 6, 2025Ultimate Addons for Elementor (Formerly Elementor Header & Footer Builder): Does not sanitize SVG file contentsCVE-2025-9703 · fixed in 2.5.0 · reported by WPScanMedium 4.3
- Aug 2, 2025Ultimate Addons for Elementor (Formerly Elementor Header & Footer Builder): Unauthorized modification of dataCVE-2025-8488 · affects up to 2.4.6 · reported by WordfenceMedium 4.3
- Dec 23, 2024Elementor Header & Footer Builder: Stored Cross-Site ScriptingCVE-2024-11230 · affects up to 1.6.46 · reported by WordfenceMedium 6.4
- Nov 8, 2024Elementor Header & Footer Builder: Stored Cross-Site ScriptingCVE-2024-10325 · affects up to 1.6.45 · reported by WordfenceMedium 6.4
- Oct 24, 2024Elementor Header & Footer Builder: Information DisclosureCVE-2024-10050 · affects up to 1.6.43 · reported by WordfenceMedium 4.3
- Jul 22, 2024Elementor – Header, Footer & Blocks Template: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-33933 · affects up to 1.6.35 · reported by PatchstackMedium 6.5
- Jun 13, 2024Elementor Header & Footer Builder: Stored Cross-Site ScriptingCVE-2024-5757 · affects up to 1.6.35 · reported by WordfenceMedium 6.4
- May 24, 2024Elementor Header & Footer Builder: Stored Cross-Site ScriptingCVE-2024-2618 · affects up to 1.6.26 · reported by WordfenceMedium 6.4
- May 16, 2024Elementor Header & Footer Builder: HTML InjectionCVE-2024-2619 · affects up to 1.6.26 · reported by WordfenceMedium 5
- May 16, 2024Elementor Header & Footer Builder: Stored Cross-Site ScriptingCVE-2024-4634 · affects up to 1.6.28 · reported by WordfenceMedium 6.4
- Mar 13, 2024Elementor Header & Footer Builder: Stored Cross-Site ScriptingCVE-2024-1237 · affects up to 1.6.24 · reported by WordfenceMedium 6.4
- May 5, 2021Ultimate Addons for Elementor: Has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users suchCVE-2021-24271 · fixed in 1.30.0 · reported by WPScanMedium 5.4
- May 5, 2021Elementor – Header, Footer & Blocks Template: Has two widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users suchCVE-2021-24256 · fixed in 1.5.8 · reported by WPScanMedium 5.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.