WordPress plugin · gutentor
Is Gutentor safe?
Safe on 4.0.6 or newer.
The current version, 4.0.6, is past every affected range on record (10 of 10 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 0
- Exploited
- none
- Current version
- 4.0.6
- Last updated
- Aug 27, 2026
- Active installs
- 30,000+
Every recorded flaw
- Sep 2, 2026Gutentor: Does not apply the correct context restriction to one of its REST endpointsCVE-2026-16983 · fixed in 4.0.6 · reported by WPScanMedium 4.3
- Apr 22, 2026Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor: Stored Cross-Site ScriptingCVE-2026-2951 · affects up to 3.5.5 · reported by WordfenceMedium 5.4
- Sep 22, 2025Gutentor: Missing AuthorizationCVE-2025-58680 · affects up to 3.5.2 · reported by PatchstackMedium 6.5
- Sep 5, 2025Gutentor: Missing AuthorizationCVE-2025-58783 · affects up to 3.5.5 · reported by PatchstackMedium 4.3
- Jul 21, 2025Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor: Stored Cross-Site ScriptingCVE-2025-4685 · affects up to 3.4.8 · reported by WordfenceMedium 6.4
- Apr 1, 2025Gutentor: Does not sanitize and escape a parameter before using it in a SQL statementCVE-2025-1986 · fixed in 3.4.7 · reported by WPScanMedium 4.1
- Jan 7, 2025Gutentor: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-22293 · affects up to 3.4.3 · reported by PatchstackMedium 6.5
- Dec 5, 2024Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor: Stored Cross-Site ScriptingCVE-2024-10178 · affects up to 3.3.9 · reported by WordfenceMedium 6.4
- Aug 29, 2024Gutentor: Does not validate and escape some of its block options before outputting them back in a page/post where the block is embedCVE-2024-5417 · fixed in 3.3.6 · reported by WPScanMedium 5.4
- Aug 18, 2024Gutentor - Gutenberg Blocks - Page Builder for Gutenberg Editor: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-43308 · affects up to 3.3.5 · reported by PatchstackMedium 6.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.