WordPress plugin · geo-my-wp
Is GEO my WP safe?
Safe on 4.5.5.7 or newer.
The current version, 4.5.5.7, is past every affected range on record (11 of 11 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 11
- High or critical
- 7
- Exploited
- none
- Current version
- 4.5.5.7
- Last updated
- Oct 23, 2026
- Active installs
- 3,000+
Every recorded flaw
- Sep 12, 2026GEO my WP: Local File InclusionCVE-2026-85200 · affects up to 4.5.5.3 · reported by Wordfence3.2% oddsHigh 7.5
- Aug 3, 2026GEO my WP: Does not perform any ownership or capability check on two of its logged-in AJAX actionsCVE-2026-15260 · fixed in 4.5.5.3 · reported by WPScanMedium 4.3
- Jul 10, 2026The GEO my WP plugin for WordPress was vulnerable to SQL Injection via the 'distance', 'lat', and 'lng' parameters in versions up to, and including, 4.5.4.CVE-2026-15300 · affects up to 4.5.4 · fixed in 4.5.5 · reported by WordfenceCritical 9.1
- Jun 16, 2026Unauthenticated SQL Injection in GEO my WordPress <= 4.5.5 versions.CVE-2026-52715 · affects up to 4.5.5 · reported by Patchstack1.2% oddsCritical 9.3
- May 30, 2026GEO my WP: SQL InjectionCVE-2026-9757 · affects up to 4.5.5 · reported by WordfenceHigh 7.5
- Dec 13, 2024GEO my: Missing AuthorizationCVE-2024-54326 · affects up to 4.5.0.4 · reported by PatchstackMedium 6.5
- Oct 6, 2024GEO my: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-47327 · affects up to 4.5.0.3 · reported by PatchstackHigh 7.1
- Aug 19, 2024GEO my WP: Does not prevent unauthenticated attackers from including arbitrary files in PHP's execution contextCVE-2024-6330 · fixed in 4.5.0.2 · reported by WPScan2.1% oddsCritical 9.8
- Apr 15, 2024GEO my: Cross-Site Request Forgery (CSRF)CVE-2024-32097 · affects up to 4.1 · reported by PatchstackMedium 5.4
- Dec 31, 2023GEO my: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2023-52134 · affects up to 4.0.2 · reported by PatchstackHigh 7.6
- Oct 10, 2023GEO my: Stored Cross-Site ScriptingCVE-2023-5467 · affects up to 4.0 · reported by WordfenceMedium 6.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.