WordPress plugin · gd-bbpress-attachments
Is forumAttachments for bbPress safe?
Safe on 5.0 or newer.
The current version, 5.0, is past every affected range on record (4 of 4 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 4
- High or critical
- 0
- Exploited
- none
- Current version
- 5.0
- Last updated
- Oct 25, 2026
- Active installs
- 6,000+
Every recorded flaw
- Nov 20, 2024GD bbPress Attachments: Reflected Cross-Site ScriptingCVE-2024-11278 · affects up to 4.7.2 · reported by WordfenceMedium 6.1
- Dec 6, 2022Auth.CVE-2022-45816 · affects up to 4.3.1 · reported by PatchstackMedium 4.8
- Aug 18, 2015Directory traversal vulnerability in the GD bbPress Attachments plugin before 2.3 for WordPress allows remote administrators to include and execute arbitrary loCVE-2015-5482 · fixed in 2.3 · reported by MITRE1.8% oddsMedium 4
- Aug 18, 2015Cross-site scripting (XSS) vulnerability in forms/panels.php in the GD bbPress Attachments plugin before 2.3 for WordPress allows remote attackers to inject arbCVE-2015-5481 · fixed in 2.3 · reported by MITRE2.1% oddsMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.