WordPress plugin · fusion-builder
Is Fusion Builder safe?
Run 3.6.2 or newer.
27 flaws are on record, 12 rated high or critical. The newest fix on record is in 3.6.2.
- Flaws on record
- 27
- High or critical
- 12
- Exploited
- none
Every recorded flaw
- Oct 28, 2026Avada (Fusion) Builder: Stored Cross-Site ScriptingCVE-2026-104729 · affects up to 3.16.2 · reported by WordfenceMedium 6.4
- Oct 14, 2026Avada (Fusion) Builder: Sensitive Information ExposureCVE-2026-97471 · affects up to 3.16.1 · reported by WordfenceMedium 5.3
- Oct 10, 2026Avada (Fusion) Builder: Authorization bypassCVE-2026-97670 · affects up to 7.16.1 · reported by WordfenceCritical 9.1
- Aug 28, 2026Avada (Fusion) Builder: Stored Cross-Site ScriptingCVE-2026-16654 · affects up to 3.15.6 · reported by WordfenceMedium 6.4
- Jul 13, 2026Avada (Fusion) Builder: Stored Cross-Site ScriptingCVE-2026-12536 · affects up to 3.15.5 · reported by WordfenceMedium 6.4
- Jun 26, 2026Contributor Privilege Escalation in Fusion Builder <= 3.15.4 versions.CVE-2026-56008 · reported by PatchstackHigh 8.8
- Jun 19, 2026Avada (Fusion) Builder: Arbitrary file deletionCVE-2026-8713 · affects up to 3.15.3 · reported by Wordfence3.0% oddsCritical 9.1
- Jun 17, 2026Contributor Arbitrary File Deletion in Fusion Builder <= 3.15.4 versions.CVE-2026-54193 · affects up to 3.15.4 · reported by PatchstackHigh 7.7
- Jun 17, 2026Contributor PHP Object Injection in Fusion Builder <= 3.15.4 versions.CVE-2026-54194 · affects up to 3.15.4 · reported by PatchstackCritical 9.8
- Jun 17, 2026Fusion Builder: Deserialization of Untrusted DataCVE-2026-12256 · affects up to 3.15.3 · reported by PatchstackHigh 8.8
- May 21, 2026Avada Builder (fusion-builder): Unauthenticated Remote Code ExecutionCVE-2026-6279 · affects up to 3.15.2 · reported by Wordfence9.9% oddsCritical 9.8
- May 21, 2026Avada (Fusion) Builder: Stored Cross-Site ScriptingCVE-2026-1543 · affects up to 3.15.2 · reported by WordfenceMedium 6.4
- Apr 15, 2026Avada (Fusion) Builder: Sensitive Information ExposureCVE-2026-1541 · affects up to 3.15.1 · reported by WordfenceMedium 4.3
- Apr 15, 2026Avada (Fusion) Builder: Arbitrary WordPress Action ExecutionCVE-2026-1509 · affects up to 3.15.1 · reported by WordfenceMedium 5.4
- Mar 25, 2026Fusion Builder: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2026-32542 · reported by PatchstackHigh 7.1
- Mar 13, 2026Fusion Builder: Missing AuthorizationCVE-2026-32452 · reported by PatchstackMedium 5.3
- Mar 13, 2026Fusion Builder: Missing AuthorizationCVE-2026-32451 · reported by PatchstackMedium 6.5
- Feb 19, 2026Fusion Builder: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2026-25472 · affects up to 3.14.1 · reported by PatchstackMedium 6.5
- Oct 22, 2025Fusion Builder: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-49940 · affects up to 3.13.2 · reported by PatchstackMedium 6.5
- Jul 16, 2025Avada (Fusion) Builder: Stored Cross-Site ScriptingCVE-2025-6747 · affects up to 3.12.1 · reported by WordfenceMedium 6.4
- Apr 1, 2025Avada (Fusion) Builder: Stored Cross-Site ScriptingCVE-2025-1665 · affects up to 3.11.14 · reported by WordfenceMedium 6.4
- Dec 25, 2024Avada (Fusion) Builder: Information ExposureCVE-2024-12335 · affects up to 3.11.12 · reported by WordfenceMedium 4.3
- Jun 19, 2024Fusion Builder: Missing AuthorizationCVE-2023-39310 · affects up to 3.11.1 · reported by PatchstackMedium 5.4
- Mar 28, 2024Fusion Builder: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2023-39309 · affects up to 3.11.1 · reported by PatchstackHigh 8.5
- Mar 27, 2024Fusion Builder: Cross-Site Request Forgery (CSRF)CVE-2023-39311 · affects up to 3.11.1 · reported by PatchstackHigh 7.1
- Mar 27, 2024Fusion Builder: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2023-39306 · affects up to 3.11.1 · reported by PatchstackHigh 7.1
- May 16, 2022The Fusion Builder WordPress plugin before 3.6.2, used in the Avada theme, does not validate a parameter in its forms which could be used to initiate arbitrary CVE-2022-1386 · fixed in 3.6.2 · reported by WPScan71% oddsCritical 9.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.