WordPress plugin · event-list
Is Event List safe?
Closed. Replace it.
wordpress.org closed it on Jan 31, 2022 (security issue), so it gets no more security fixes, and 3 flaws are on record. If your site runs it, move to a maintained alternative.
- Flaws on record
- 3
- High or critical
- 2
- Exploited
- none
Every recorded flaw
- Aug 26, 2025Event List: Privilege escalationCVE-2025-6366 · affects up to 2.0.4 · reported by WordfenceHigh 8.8
- May 2, 2022Event List: Does not sanitise and escape some of its settingsCVE-2022-0418 · fixed in 0.8.8 · reported by WPScanMedium 4.8
- Jun 13, 2017SQL injection vulnerability in the Event List plugin 0.7.8 for WordPress allows an authenticated user to execute arbitrary SQL commands via the id parameter to CVE-2017-9429 · affects 0.7.8 to 0.7.8 · reported by MITRE2.7% oddsHigh 8.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.