WordPress plugin · etsy-shop
Is Etsy Shop safe?
Safe on 3.1 or newer.
The current version, 3.1, is past every affected range on record (3 of 3 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 3
- High or critical
- 0
- Exploited
- none
- Current version
- 3.1
- Last updated
- Aug 31, 2026
- Active installs
- 3,000+
Every recorded flaw
- Sep 22, 2025Etsy Shop: Does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attributeCVE-2025-9115 · fixed in 3.0.7 · reported by WPScanMedium 5.6
- Nov 9, 2023Cross-Site Request Forgery (CSRF) vulnerability in Frédéric Sheedy Etsy Shop plugin <= 3.0.3 versions.CVE-2023-25975 · fixed in 3.0.4 · reported by PatchstackMedium 5.4
- Oct 12, 2023Etsy Shop: Stored Cross-Site ScriptingCVE-2023-5470 · affects up to 3.0.4 · reported by WordfenceMedium 6.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.