WordPress plugin · essential-blocks
Is Gutenberg Essential Blocks safe?
Safe on 6.5.2 or newer.
The current version, 6.5.2, is past every affected range on record (35 of 35 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 35
- High or critical
- 6
- Exploited
- none
- Current version
- 6.5.2
- Last updated
- Oct 27, 2026
- Active installs
- 100,000+
Every recorded flaw
- Oct 1, 2026Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns: Stored Cross-Site ScriptingCVE-2026-96256 · affects up to 6.4.5 · reported by WordfenceMedium 6.4
- Aug 6, 2026Gutenberg Essential Blocks: Does not verify that an attacker-supplied post type is publicly viewable before querying it in one of its public REST routesCVE-2026-13154 · fixed in 6.4.0 · reported by WPScanHigh 7.5
- Aug 6, 2026Gutenberg Essential Blocks: Does not restrict access to one of its public REST routes and over-fetches a non-public WooCommerce per-product sales metric into the responseCVE-2026-13153 · fixed in 6.4.0 · reported by WPScan1.5% oddsHigh 7.5
- Jun 25, 2026Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns: Stored Cross-Site ScriptingCVE-2026-10833 · affects up to 6.1.4 · reported by WordfenceMedium 6.4
- Jun 4, 2026Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns: Server-Side Request ForgeryCVE-2026-10586 · affects up to 6.1.3 · reported by WordfenceHigh 7.2
- May 2, 2026Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates: Stored Cross-Site ScriptingCVE-2026-4658 · affects up to 6.0.4 · reported by WordfenceMedium 6.4
- Dec 16, 2025Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns: Unauthorized access of dataCVE-2025-11369 · affects up to 5.7.2 · reported by WordfenceMedium 4.3
- Oct 18, 2025Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns: Stored Cross-Site ScriptingCVE-2025-11270 · affects up to 5.7.1 · reported by WordfenceMedium 6.4
- Oct 18, 2025Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns: Server-Side Request ForgeryCVE-2025-11361 · affects up to 5.7.1 · reported by WordfenceMedium 6.4
- May 26, 2025Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates: Stored Cross-Site ScriptingCVE-2025-4682 · affects up to 5.4.0 · reported by WordfenceMedium 6.4
- Mar 8, 2025Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates: Stored Cross-Site ScriptingCVE-2025-1664 · affects up to 5.3.1 · reported by WordfenceMedium 6.4
- Feb 26, 2025Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates: Stored Cross-Site ScriptingCVE-2024-13803 · affects up to 5.2.3 · reported by WordfenceMedium 6.4
- Feb 25, 2025Essential Blocks for Gutenberg: Missing AuthorizationCVE-2025-26871 · affects up to 4.8.3 · reported by PatchstackMedium 4.3
- Jan 8, 2025Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates: Stored Cross-Site ScriptingCVE-2024-12045 · affects up to 5.0.9 · reported by WordfenceMedium 4.4
- Dec 13, 2024Essential Blocks for Gutenberg: Missing AuthorizationCVE-2022-47594 · affects up to 3.8.5 · reported by PatchstackMedium 6.5
- Dec 9, 2024Essential Blocks for Gutenberg: Missing AuthorizationCVE-2023-51360 · affects up to 4.2.0 · reported by PatchstackMedium 6.5
- Dec 9, 2024Essential Blocks for Gutenberg: Missing AuthorizationCVE-2023-51359 · affects up to 4.2.0 · reported by PatchstackMedium 5.4
- Dec 9, 2024Essential Blocks for Gutenberg: Missing AuthorizationCVE-2023-47760 · affects up to 4.2.0 · reported by PatchstackMedium 4.3
- Oct 5, 2024Essential Blocks for Gutenberg: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-47385 · affects up to 4.8.4 · reported by PatchstackMedium 6.5
- Aug 2, 2024Essential Blocks: Does not validate and escape some of its block options before outputting them back in a page/post where the block is embedCVE-2024-5595 · fixed in 4.7.0 · reported by WPScanMedium 5.4
- Jun 9, 2024Essential Blocks for Gutenberg: Missing AuthorizationCVE-2024-30467 · affects up to 4.4.9 · reported by PatchstackMedium 6.5
- May 18, 2024Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates: Stored Cross-Site ScriptingCVE-2024-4891 · affects up to 4.5.12 · reported by WordfenceMedium 6.4
- Apr 18, 2024Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates: Stored Cross-Site ScriptingCVE-2024-3818 · affects up to 4.5.9 · reported by WordfenceMedium 5.4
- Apr 7, 2024Essential Blocks for Gutenberg: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-31306 · affects up to 4.5.3 · reported by PatchstackMedium 6.5
- Mar 20, 2024Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates: Stored Cross-Site ScriptingCVE-2024-2255 · affects up to 4.5.3 · reported by WordfenceMedium 6.4
- Mar 13, 2024Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates: Stored Cross-Site ScriptingCVE-2024-1854 · affects up to 4.5.1 · reported by WordfenceMedium 6.4
- Jan 15, 2024Essential Blocks: Does not prevent unauthenticated attackers from overwriting local variablesCVE-2023-6623 · fixed in 4.4.3 · reported by WPScan51% oddsCritical 9.8
- Jan 11, 2024Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates: Stored Cross-Site ScriptingCVE-2023-7071 · affects up to 4.4.6 · reported by WordfenceMedium 6.4
- Oct 20, 2023Essential Blocks: PHP Object InjectionCVE-2023-4386 · affects up to 4.2.0 · reported by WordfenceHigh 8.1
- Oct 20, 2023Essential Blocks: PHP Object InjectionCVE-2023-4402 · affects up to 4.2.0 · reported by Wordfence1.5% oddsHigh 8.1
- Jun 9, 2023Essential Blocks: Cross-Site Request ForgeryCVE-2023-2087 · affects up to 4.0.6 · reported by WordfenceMedium 4.3
- Jun 9, 2023Essential Blocks: Unauthorized use of functionalityCVE-2023-2086 · affects up to 4.0.6 · reported by WordfenceMedium 4.3
- Jun 9, 2023Essential Blocks: Unauthorized use of functionalityCVE-2023-2085 · affects up to 4.0.6 · reported by WordfenceMedium 4.3
- Jun 9, 2023Essential Blocks: Unauthorized use of functionalityCVE-2023-2084 · affects up to 4.0.6 · reported by WordfenceMedium 4.3
- Jun 9, 2023Essential Blocks: Unauthorized use of functionalityCVE-2023-2083 · affects up to 4.0.6 · reported by WordfenceMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.