WordPress plugin · ecwid-shopping-cart
Is Ecwid by Lightspeed Ecommerce Shopping Cart safe?
Safe on 7.0.10 or newer.
The current version, 7.0.10, is past every affected range on record (12 of 12 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 12
- High or critical
- 2
- Exploited
- none
- Current version
- 7.0.10
- Last updated
- Oct 1, 2026
- Active installs
- 20,000+
Every recorded flaw
- Aug 13, 2026Ecwid by Lightspeed Ecommerce Shopping Cart: Does not perform a capability check or nonce verification on one of its store-management actionsCVE-2026-14332 · fixed in 7.0.9 · reported by WPScanMedium 5.4
- Feb 14, 2026Ecwid by Lightspeed Ecommerce Shopping Cart: Privilege EscalationCVE-2026-1750 · affects up to 7.0.7 · reported by WordfenceHigh 8.8
- Jan 23, 2026Ecwid Shopping Cart: Missing AuthorizationCVE-2026-24613 · affects up to 7.0.6 · reported by PatchstackMedium 5.3
- Jan 23, 2026Ecwid Shopping Cart: Missing AuthorizationCVE-2026-24580 · affects up to 7.0.5 · reported by PatchstackMedium 4.3
- Apr 4, 2025Ecwid Shopping Cart: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-32195 · affects up to 7.0 · reported by PatchstackMedium 6.5
- Feb 18, 2025Ecwid by Lightspeed Ecommerce Shopping Cart: Cross-Site Request ForgeryCVE-2024-13795 · affects up to 6.12.27 · reported by WordfenceMedium 4.3
- Apr 9, 2024Ecwid Ecommerce Shopping Cart: Stored Cross-Site ScriptingCVE-2024-2456 · affects up to 6.12.10 · reported by WordfenceMedium 6.4
- Feb 28, 2024Ecwid Ecommerce Shopping Cart: Cross-Site Request Forgery (CSRF)CVE-2023-51533 · affects up to 6.12.4 · reported by PatchstackMedium 5.4
- Jan 16, 2024Ecwid Ecommerce Shopping Cart: Does not have CSRF check in placeCVE-2023-6292 · fixed in 6.12.5 · reported by WPScanMedium 4.3
- May 8, 2023Auth.CVE-2023-24408 · fixed in 6.11.5 · reported by PatchstackMedium 6.5
- Feb 14, 2023Cross-Site Request Forgery (CSRF) vulnerability in Ecwid Ecommerce Ecwid Ecommerce Shopping Cart plugin <= 6.11.3 versions.CVE-2023-24377 · affects up to 6.11.3 · reported by PatchstackMedium 5.4
- Sep 6, 2022Ecwid Ecommerce Shopping Cart: Cross-Site Request ForgeryCVE-2022-2432 · affects up to 6.10.23 · reported by WordfenceHigh 8.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.