WordPress plugin · ebook-store
Is Ebook Store safe?
Safe on 6.26 or newer.
The current version, 6.26, is past every affected range on record (16 of 16 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 16
- High or critical
- 4
- Exploited
- none
- Current version
- 6.26
- Last updated
- Oct 27, 2026
- Active installs
- 700+
Every recorded flaw
- Jul 27, 2026Unauthenticated Sensitive Data Exposure in Ebook Store <= 6.19 versions.CVE-2026-59529 · affects up to 6.19 · reported by PatchstackHigh 7.5
- Jul 23, 2026Unauthenticated Broken Access Control in Ebook Store <= 6.19 versions.CVE-2026-65453 · affects up to 6.19 · reported by PatchstackMedium 5.3
- Jul 23, 2026Unauthenticated Broken Access Control in Ebook Store <= 6.19 versions.CVE-2026-65452 · affects up to 6.19 · reported by PatchstackMedium 5.3
- Aug 16, 2025Ebook Store: Does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attributeCVE-2025-8113 · fixed in 5.8015 · reported by WPScanMedium 6.1
- Aug 14, 2025Ebook Store: Cross-Site Request Forgery (CSRF)CVE-2025-54702 · affects up to 5.8013 · reported by PatchstackMedium 4.3
- Jul 24, 2025Ebook Store: Arbitrary file uploadsCVE-2025-7437 · affects up to 5.8012 · reported by Wordfence1.5% oddsCritical 9.8
- Jul 21, 2025Ebook Store: Stored Cross-Site ScriptingCVE-2025-7486 · affects up to 5.8012 · reported by WordfenceMedium 4.4
- Jun 17, 2025Ebook Store: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-49862 · affects up to 5.8008 · reported by PatchstackMedium 5.9
- May 7, 2025Ebook Store: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-47589 · affects up to 5.8009 · reported by PatchstackMedium 6.5
- Dec 21, 2024Ebook Store: Reflected Cross-Site ScriptingCVE-2024-12262 · affects up to 5.8001 · reported by WordfenceMedium 6.1
- Dec 21, 2024Ebook Store: Reflected Cross-Site ScriptingCVE-2024-11287 · affects up to 5.8001 · reported by WordfenceMedium 6.1
- Dec 9, 2024Ebook Store: Missing AuthorizationCVE-2023-22701 · affects up to 5.775 · reported by Patchstack1.0% oddsHigh 7.5
- Aug 1, 2024Ebook Store: Full Path DisclosureCVE-2024-6567 · affects up to 5.8001 · reported by WordfenceMedium 5.3
- Feb 29, 2024Ebook Store: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-23501 · affects up to 5.788 · reported by PatchstackMedium 5.9
- Oct 18, 2023Unauth.CVE-2023-45602 · affects up to 5.785 · reported by PatchstackHigh 7.1
- May 15, 2023Auth.CVE-2023-22690 · affects up to 5.775 · reported by PatchstackMedium 5.9
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.