WordPress plugin · easy-form-builder
Is Easy Form Builder by WhiteStudio safe?
Safe on 4.3.0 or newer.
The current version, 4.3.0, is past every affected range on record (13 of 13 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 13
- High or critical
- 7
- Exploited
- none
- Current version
- 4.3.0
- Last updated
- Oct 1, 2026
- Active installs
- 1,000+
Every recorded flaw
- Sep 18, 2026Easy Form Builder by WhiteStudio: Does not validate a submitted value against the stored configuration for some of its form typesCVE-2026-85123 · fixed in 4.2.0 · reported by WPScanMedium 5.3
- Sep 18, 2026Easy Form Builder by WhiteStudio: Does not validate a submitted value against the stored configuration for some of its form typesCVE-2026-85122 · fixed in 4.2.0 · reported by WPScanHigh 8.8
- Jul 23, 2026Unauthenticated Cross Site Scripting (XSS) in Easy Form Builder <= 4.0.12 versions.CVE-2026-59517 · affects up to 4.0.12 · reported by PatchstackHigh 7.1
- Jul 21, 2026Easy Form Builder by WhiteStudio: Unauthenticated Privilege Escalation to AdministratorCVE-2026-13439 · affects up to 4.0.11 · reported by WordfenceCritical 9.8
- May 27, 2026Easy Form Builder: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2026-42747 · affects up to 4.0.6 · reported by PatchstackCritical 9.3
- Feb 13, 2026Easy Form Builder: Unauthorized access of dataCVE-2025-14067 · affects up to 3.9.3 · reported by WordfenceMedium 5.3
- Jan 22, 2026Easy Form Builder: Missing AuthorizationCVE-2026-22472 · affects up to 3.9.6 · reported by PatchstackMedium 4.3
- Dec 9, 2025Easy Form Builder: Missing AuthorizationCVE-2025-67577 · affects up to 3.8.20 · reported by PatchstackMedium 5.3
- Aug 14, 2025Easy Form Builder: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2025-54678 · affects up to 3.8.15 · reported by PatchstackCritical 9.3
- Jan 7, 2025Easy Form Builder – WordPress plugin form builder: contact form, survey form, payment form, and custom form builder: Stored Cross-Site ScriptingCVE-2024-12112 · affects up to 3.8.8 · reported by WordfenceMedium 6.4
- Mar 31, 2024Easy Form Builder: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2024-30535 · affects up to 3.7.4 · reported by PatchstackHigh 8.5
- Dec 12, 2022Easy Form Builder: Does not sanitise and escape some of its settingsCVE-2022-3906 · fixed in 3.4.0 · reported by WPScanMedium 4.8
- Apr 12, 2021The EFBP_verify_upload_file AJAX action of the Easy Form Builder WordPress plugin through 1.0, available to authenticated users, does not have any security in pCVE-2021-24224 · affects up to 1.0 · reported by WPScan1.9% oddsHigh 8.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.