WordPress plugin · easy-appointments
Is Easy Appointments safe?
Safe on 4.0.4 or newer.
The current version, 4.0.4, is past every affected range on record (24 of 24 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 24
- High or critical
- 4
- Exploited
- none
- Current version
- 4.0.4
- Last updated
- Oct 21, 2026
- Active installs
- 10,000+
Every recorded flaw
- Sep 19, 2026Easy Appointments: Sensitive Information ExposureCVE-2026-9232 · affects up to 3.12.27 · reported by WordfenceMedium 6.5
- Sep 18, 2026Easy Appointments: Does not perform an ownership or authorization check on its unauthenticated appointment-reservation endpoint before updating an existing appointment identified by a request-supplied idCVE-2026-87966 · fixed in 4.0.2.2 · reported by WPScanMedium 5.3
- Sep 18, 2026Easy Appointments: Does not use an unguessable token to authorize its mail-link appointment cancellation and confirmation actionCVE-2026-87965 · fixed in 4.0.2.2 · reported by WPScanMedium 4.8
- Sep 8, 2026Easy Appointments: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2026-81798 · affects up to 4.0.2.1 · reported by PatchstackHigh 7.1
- Aug 19, 2026Easy Appointments: Does not restrict one of its appointment-listing REST endpoints to the records belonging to the requesting userCVE-2026-19406 · fixed in 4.0.1 · reported by WPScanLow 2.7
- Aug 6, 2026Easy Appointments: Does not correctly validate shortcode input in one of its block-rendering actionsCVE-2026-14225 · fixed in 3.12.28 · reported by WPScanLow 2.7
- Jul 30, 2026Easy Appointments: Does not require a sufficient capability on one of its appointment-listing REST endpointsCVE-2026-14226 · fixed in 3.12.28 · reported by WPScanMedium 4.3
- Jul 30, 2026Easy Appointments: Does not verify ownership or capabilityCVE-2026-14223 · fixed in 3.12.28 · reported by WPScanMedium 4.3
- Jul 30, 2026Easy Appointments: Does not perform any capability or nonce check in one of its connection-deletion actionsCVE-2026-14222 · fixed in 3.12.28 · reported by WPScanLow 3.8
- Jul 30, 2026Easy Appointments: Does not perform capability checks in several of its appointment-management actionsCVE-2026-14221 · affects up to 4.0 · reported by WPScanLow 3.8
- Jul 30, 2026Easy Appointments: Does not perform a per-request capability or nonce check on one of its customer-listing handlersCVE-2026-14188 · fixed in 3.12.28 · reported by WPScanLow 2.7
- Jul 29, 2026Easy Appointments: Does not verify that the appointment targeted by its customer-data update action belongs to the current user; the action only checks a shared nonce that any authenticated user can obtain from their ownCVE-2026-14224 · fixed in 3.12.28 · reported by WPScanMedium 5.4
- Jul 24, 2026Easy Appointments: Unauthorized modification of dataCVE-2026-8789 · affects up to 3.12.27 · reported by WordfenceHigh 8.1
- Jul 23, 2026Unauthenticated Insecure Direct Object References (IDOR) in Easy Appointments <= 3.12.27 versions.CVE-2026-61946 · affects up to 3.12.27 · reported by PatchstackMedium 6.5
- Jul 10, 2026Easy Appointments: Authorization bypassCVE-2026-11992 · affects up to 3.12.27 · reported by WordfenceMedium 4.3
- Jun 15, 2026Unauthenticated Broken Access Control in Easy Appointments <= 3.12.21 versions.CVE-2026-39513 · affects up to 3.12.21 · reported by PatchstackHigh 7.5
- Apr 17, 2026Easy Appointments: Sensitive Information ExposureCVE-2026-2262 · affects up to 3.12.21 · reported by Wordfence2.4% oddsHigh 7.5
- Nov 6, 2025Easy Appointments: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)CVE-2025-49398 · affects up to 3.12.14 · reported by PatchstackMedium 6.5
- Dec 9, 2024Easy Appointments: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2023-30748 · affects up to 3.10.7 · reported by PatchstackMedium 4.3
- Mar 29, 2024Easy Appointments: Unauthorized modification of dataCVE-2024-2844 · affects up to 3.11.18 · reported by WordfenceMedium 4.3
- Mar 29, 2024Easy Appointments: Stored Cross-Site ScriptingCVE-2024-2842 · affects up to 3.11.18 · reported by WordfenceMedium 6.4
- Jul 17, 2023Cross-Site Request Forgery (CSRF) vulnerability in Nikola Loncar Easy Appointments plugin <= 3.11.9 versions.CVE-2022-36424 · affects up to 3.11.9 · reported by PatchstackMedium 4.3
- Jan 23, 2023Easy Appointments: Does not validate and escape some of its shortcode attributes before outputting them back in the pageCVE-2022-4668 · fixed in 3.11.2 · reported by WPScanMedium 5.4
- Oct 23, 2017The Easy Appointments plugin before 1.12.0 for WordPress has XSS via a Settings values in the admin panel.CVE-2017-15812 · fixed in 1.12.0 · reported by MITREMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.