WordPress plugin · delicious-recipes
Is WP Delicious safe?
Safe on 1.10.10 or newer.
The current version, 1.10.10, is past every affected range on record (10 of 10 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 2
- Exploited
- none
- Current version
- 1.10.10
- Last updated
- Oct 8, 2026
- Active installs
- 4,000+
Every recorded flaw
- Sep 26, 2026WP Delicious: Does not validate or escape the HTML tag name taken from user-supplied recipe block data before rendering it on the front endCVE-2026-92411 · fixed in 1.10.8 · reported by WPScanMedium 6.8
- Jul 30, 2026WP Delicious: Does not perform an authorization check on one of its AJAX actionsCVE-2026-14305 · fixed in 1.10.2 · reported by WPScanMedium 5.3
- Jul 16, 2026Delicious Recipes: Stored Cross-Site ScriptingCVE-2026-15099 · affects up to 1.10.2 · reported by WordfenceMedium 6.4
- Apr 8, 2026WP Delicious: Missing AuthorizationCVE-2026-39528 · affects up to 1.9.5 · reported by PatchstackMedium 5.3
- Dec 9, 2025WP Delicious: Missing AuthorizationCVE-2025-67548 · affects up to 1.9.1 · reported by PatchstackMedium 6.5
- Nov 1, 2025WP Delicious – Recipe Plugin for Food Bloggers (formerly Delicious Recipes): Arbitrary file uploads when importing recipesCVE-2025-11755 · affects up to 1.9.0 · reported by WordfenceHigh 8.8
- Sep 3, 2025WP Delicious: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-58605 · affects up to 1.8.7 · reported by PatchstackMedium 6.5
- Jul 16, 2025WP Delicious: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-54023 · affects up to 1.8.4 · reported by PatchstackMedium 6.5
- Sep 11, 2024WP Delicious – Recipe Plugin for Food Bloggers (formerly Delicious Recipes): Arbitrary file movement and readingCVE-2024-7626 · affects up to 1.6.9 · reported by WordfenceHigh 8.1
- Aug 29, 2024Delicious Recipes – WordPress Recipe: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-43935 · affects up to 1.6.7 · reported by PatchstackMedium 6.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.