WordPress plugin · dc-woocommerce-multi-vendor
Is MultiVendorX safe?
Safe on 5.0.21 or newer.
The current version, 5.0.21, is past every affected range on record (27 of 27 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 27
- High or critical
- 13
- Exploited
- none
- Current version
- 5.0.21
- Last updated
- Oct 29, 2026
- Active installs
- 2,000+
Every recorded flaw
- Oct 10, 2026MultiVendorX WordPress plugin through 5.0.19 contains an incorrect authorization vulnerability that allows vendor accounts to modify marketplace-wide settings vCVE-2026-108695 · affects up to 5.0.19 · reported by VulnCheckHigh 7.1
- Oct 2, 2026Dc Woocommerce Multi Vendor: SQL InjectionCVE-2026-12951 · affects up to 5.0.18 · reported by WordfenceMedium 6.5
- Sep 16, 2026MultiVendorX: Does not verify that a user owns the store they are acting on in one of its REST API routesCVE-2026-74926 · fixed in 5.0.16 · reported by WPScanHigh 7.1
- Sep 11, 2026MultiVendorX: Does not restrict who can update its role and capability settingsCVE-2026-74925 · fixed in 5.0.16 · reported by WPScanHigh 7.2
- Sep 2, 2026MultiVendorX: Does not have proper authorisation controls on one of its REST API listing routesCVE-2026-74927 · fixed in 5.0.15 · reported by WPScanMedium 5.3
- Aug 18, 2026MultiVendorX: Missing AuthorizationCVE-2026-66651 · affects up to 5.0.20 · reported by PatchstackMedium 6.5
- Aug 13, 2026Unauthenticated Broken Access Control in MultiVendorX <= 5.0.10 versions.CVE-2026-66441 · affects up to 5.0.10 · reported by PatchstackHigh 7.5
- Aug 5, 2026MultiVendorX: Does not verify that the requested store belongs to the current user in one of its REST API endpointsCVE-2026-16746 · fixed in 5.0.11 · reported by WPScanLow 2.7
- Aug 5, 2026MultiVendorX: Does not verify that the store targeted through its REST API belongs to the requesting vendorCVE-2026-16605 · fixed in 5.0.11 · reported by WPScanHigh 7.2
- Jul 16, 2026MultiVendorX – WooCommerce Multivendor Marketplace AI Powered Solutions: Generic SQL InjectionCVE-2026-12941 · affects up to 5.0.9 · reported by WordfenceMedium 6.5
- Oct 22, 2025MultiVendorX: Missing AuthorizationCVE-2025-49916 · affects up to 4.2.23 · reported by PatchstackHigh 8.6
- Jun 9, 2025MultiVendorX: Insertion of Sensitive Information Into Sent DataCVE-2025-48261 · affects up to 4.2.22 · reported by PatchstackHigh 7.5
- May 19, 2025MultiVendorX: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-48263 · affects up to 4.2.22 · reported by PatchstackMedium 6.5
- May 17, 2025MultiVendorX – WooCommerce Multivendor Marketplace Solutions: Unauthorized loss of dataCVE-2025-4101 · affects up to 4.2.22 · reported by WordfenceMedium 4.3
- Apr 5, 2025MultiVendorX – Empower Your WooCommerce Store with a Dynamic Multivendor Marketplace – Build the Next Amazon, eBay, Etsy: Unauthorized loss of dataCVE-2025-2789 · affects up to 4.2.19 · reported by WordfenceMedium 5.3
- Jan 31, 2025MultiVendorX – The Ultimate WooCommerce Multivendor Marketplace Solution: Limited Local File InclusionCVE-2025-0493 · affects up to 4.2.14 · reported by Wordfence1.0% oddsCritical 9.8
- Jan 24, 2025MultiVendorX: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-24706 · affects up to 4.2.13 · reported by PatchstackMedium 6.5
- Dec 9, 2024MultiVendorX: Missing AuthorizationCVE-2023-51355 · affects up to 4.0.23 · reported by PatchstackHigh 8.2
- Oct 24, 2024MultiVendorX – The Ultimate WooCommerce Multivendor Marketplace Solution: Cross-Site Request ForgeryCVE-2024-9943 · affects up to 4.2.4 · reported by WordfenceMedium 6.3
- Oct 24, 2024MultiVendorX – The Ultimate WooCommerce Multivendor Marketplace Solution: Unauthorized modification of dataCVE-2024-9531 · affects up to 4.2.4 · reported by WordfenceMedium 4.3
- Sep 4, 2024MultiVendorX – The Ultimate WooCommerce Multivendor Marketplace Solution: Privilege escalation/de-escalation and account takeoverCVE-2024-8289 · affects up to 4.2.0 · reported by Wordfence1.3% oddsCritical 9.8
- Aug 12, 2024WC Marketplace: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-43213 · affects up to 4.1.17 · reported by PatchstackHigh 7.1
- Jun 11, 2024WC Marketplace: Missing AuthorizationCVE-2024-24703 · affects up to 4.0.25 · reported by PatchstackHigh 8.6
- Jun 9, 2024WC Marketplace: Missing AuthorizationCVE-2024-31304 · affects up to 4.1.3 · reported by PatchstackHigh 7.1
- Jun 6, 2024MultiVendorX Marketplace – WooCommerce MultiVendor Marketplace Solution: Stored Cross-Site ScriptingCVE-2024-5259 · affects up to 4.1.11 · reported by WordfenceMedium 6.4
- Mar 29, 2024WC Marketplace: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-30433 · affects up to 4.1.3 · reported by PatchstackMedium 6.5
- Jul 1, 2023MultiVendorX: Cross-Site Request ForgeryCVE-2020-36741 · affects up to 3.5.7 · reported by WordfenceMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.