WordPress plugin · customer-area
Is WP Customer Area safe?
Safe on 8.4.1 or newer.
The current version, 8.4.1, is past every affected range on record (12 of 12 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 12
- High or critical
- 4
- Exploited
- none
- Current version
- 8.4.1
- Last updated
- Oct 26, 2026
- Active installs
- 10,000+
Every recorded flaw
- Jul 13, 2026WP Customer Area: Stored Cross-Site ScriptingCVE-2026-7640 · affects up to 8.3.5 · reported by WordfenceMedium 6.4
- Jun 15, 2026Custom role Path Traversal in WP Customer Area <= 8.3.4 versions.CVE-2026-42661 · affects up to 8.3.4 · reported by PatchstackHigh 8.8
- Apr 17, 2026WP Customer Area: Arbitrary file read and deletionCVE-2026-3464 · affects up to 8.3.4 · reported by WordfenceHigh 8.8
- Nov 6, 2025aguilatechnologies WP Customer Area customer-area: Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')CVE-2025-60201 · fixed in 8.3.4 · reported by PatchstackHigh 7.5
- Jun 20, 2025WP Customer Area: Missing AuthorizationCVE-2025-49982 · affects up to 8.3.4 · reported by PatchstackMedium 4.3
- Jan 27, 2025WP Customer Area: Does not have CSRF checks in some placesCVE-2024-12436 · affects up to 8.2.4 · reported by WPScanMedium 4.3
- Jan 27, 2025WP Customer Area: Does not have CSRF check in placeCVE-2024-12280 · affects up to 8.2.4 · reported by WPScanMedium 4.3
- Jan 24, 2024WP Customer Area: Reflected Cross-Site ScriptingCVE-2024-0665 · affects up to 8.2.1 · reported by WordfenceMedium 6.1
- Jan 16, 2024WP Customer Area: Does not properly validates user capabilities in some of its AJAX actionsCVE-2023-6824 · fixed in 8.2.1 · reported by WPScanMedium 6.5
- Jan 16, 2024WP Customer Area: Does not properly validate users capabilities in some of its AJAX actionsCVE-2023-6741 · fixed in 8.2.1 · reported by WPScanMedium 4.3
- Feb 13, 2023WP Customer Area: Does not have CSRF checksCVE-2022-4745 · fixed in 8.1.4 · reported by WPScanHigh 7.1
- Aug 20, 2019The customer-area plugin before 7.4.3 for WordPress has XSS via admin pages.CVE-2017-18519 · fixed in 7.4.3 · reported by MITREMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.