WordPress plugin · cubewp-framework
Is CubeWP Framework safe?
Safe on 1.1.31 or newer.
The current version, 1.1.31, is past every affected range on record (16 of 16 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 16
- High or critical
- 7
- Exploited
- none
- Current version
- 1.1.31
- Last updated
- Jul 29, 2026
- Active installs
- 3,000+
Every recorded flaw
- Aug 13, 2026Subscriber SQL Injection in CubeWP <= 1.1.30 versions.CVE-2026-28168 · affects up to 1.1.30 · reported by PatchstackHigh 8.5
- Aug 10, 2026CubeWP Framework: Does not perform a per-object read authorization checkCVE-2026-17018 · affects up to 1.1.30 · reported by WPScanMedium 4.9
- Aug 9, 2026CubeWP Framework: Does not properly sanitize and escape a parameter before using it in a SQL statement through an AJAX actionCVE-2026-17017 · fixed in 1.1.31 · reported by WPScanHigh 8.1
- Aug 1, 2026CubeWP Framework: Directory TraversalCVE-2026-13339 · affects up to 1.1.30 · reported by WordfenceHigh 7.5
- Aug 1, 2026CubeWP Framework: SQL InjectionCVE-2026-6453 · affects up to 1.1.30 · reported by WordfenceMedium 6.5
- Jan 24, 2026CubeWP – All-in-One Dynamic Content Framework: Information ExposureCVE-2025-6461 · affects up to 1.1.27 · reported by WordfenceMedium 4.3
- Jan 17, 2026CubeWP: Stored Cross-Site ScriptingCVE-2025-8615 · affects up to 1.1.26 · reported by WordfenceMedium 6.4
- Jan 17, 2026CubeWP – All-in-One Dynamic Content Framework: Information ExposureCVE-2025-12129 · affects up to 1.1.27 · reported by WordfenceMedium 5.3
- Dec 29, 2025CubeWP: Missing AuthorizationCVE-2025-68036 · affects up to 1.1.27 · reported by PatchstackHigh 7.5
- Sep 22, 2025CubeWP: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-59569 · affects up to 1.1.26 · reported by PatchstackMedium 6.5
- Aug 20, 2025CubeWP: Incorrect Privilege AssignmentCVE-2025-54735 · affects up to 1.1.24 · reported by PatchstackHigh 8.8
- Jun 17, 2025CubeWP: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-49882 · affects up to 1.1.23 · reported by PatchstackMedium 6.5
- Jun 11, 2025CubeWP – All-in-One Dynamic Content Framework: Privilege EscalationCVE-2025-4315 · affects up to 1.1.23 · reported by WordfenceHigh 8.8
- Jun 6, 2025CubeWP: Cross-Site Request Forgery (CSRF)CVE-2025-30994 · affects up to 1.1.29 · reported by PatchstackMedium 4.3
- Nov 1, 2024CubeWP: Missing AuthorizationCVE-2024-48039 · affects up to 1.1.15 · reported by PatchstackMedium 4.3
- Mar 29, 2024CubeWP – All-in-One Dynamic Content Framework: Unrestricted Upload of File with Dangerous TypeCVE-2024-30500 · affects up to 1.1.12 · reported by PatchstackCritical 9.9
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.