WordPress plugin · crayon-syntax-highlighter
Is Crayon Syntax Highlighter safe?
Closed. Replace it.
wordpress.org closed it on Dec 13, 2022 (security issue), so it gets no more security fixes, and 3 flaws are on record. If your site runs it, move to a maintained alternative.
- Flaws on record
- 3
- High or critical
- 0
- Exploited
- none
Every recorded flaw
- Sep 11, 2023Crayon Syntax Highlighter: Server Side Request ForgeryCVE-2023-4893 · affects up to 2.8.4 · reported by WordfenceMedium 6.4
- May 22, 2023Cross-Site Request Forgery (CSRF) vulnerability in Aram Kocharyan Crayon Syntax Highlighter plugin <= 2.8.4 versions.CVE-2022-47167 · affects up to 2.8.4 · reported by PatchstackMedium 5.4
- Aug 20, 2019The crayon-syntax-highlighter plugin before 2.8.4 for WordPress has multiple XSS issues via AJAX requests.CVE-2016-10893 · fixed in 2.8.4 · reported by MITRE1.5% oddsMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.