WordPress plugin · buddypress-extended-friendship-request
Is BuddyPress Extended Friendship Request safe?
A flaw affects the current version.
The newest release on wordpress.org, 1.2.2, is inside the affected range of CVE-2014-1888, so there may be no fix yet. Check the changelog; if it doesn’t mention the fix, deactivate it until it does.
- Flaws on record
- 2
- High or critical
- 0
- Exploited
- none
- Current version
- 1.2.2
- Last updated
- Aug 16, 2025
- Active installs
- 300+
Every recorded flaw
- Feb 28, 2014Cross-site scripting (XSS) vulnerability in the BuddyPress plugin before 1.9.2 for WordPress allows remote authenticated users to inject arbitrary web script orCVE-2014-1888 · fixed in 1.9.2 · reported by MITRE2.6% oddsMedium 4.3
- Jul 29, 2013Cross-site scripting (XSS) vulnerability in the BuddyPress Extended Friendship Request plugin before 1.0.2 for WordPress, when the "Friend Connections" componenCVE-2013-4944 · fixed in 1.0.2 · reported by MITRE2.1% oddsLow 2.6
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.