WordPress plugin · broken-link-checker
Is Broken Link Checker safe?
Safe on 2.4.15 or newer.
The current version, 2.4.15, is past every affected range on record (17 of 17 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 17
- High or critical
- 5
- Exploited
- none
- Current version
- 2.4.15
- Last updated
- Oct 13, 2026
- Active installs
- 500,000+
Every recorded flaw
- Oct 16, 2026The Broken Link Checker: Arbitrary shortcode executionCVE-2026-96562 · affects up to 2.4.14.1 · reported by WordfenceMedium 6.5
- Oct 15, 2026Broken Link Checker: Improper Control of Generation of Code ('Code Injection')CVE-2026-102389 · affects up to 2.4.14.1 · reported by PatchstackMedium 6.5
- Sep 2, 2026Editor Server Side Request Forgery (SSRF) in Broken Link Checker <= 2.4.14 versions.CVE-2026-84772 · affects up to 2.4.14 · reported by PatchstackMedium 5.5
- Sep 2, 2026Broken Link Checker: Stored Cross-Site ScriptingCVE-2026-75528 · affects up to 2.4.13 · reported by WordfenceHigh 7.2
- Aug 19, 2026Broken Link Checker: Does not limitCVE-2026-18937 · fixed in 2.4.12 · reported by WPScan2.0% oddsCritical 9
- Apr 8, 2026Broken Link Checker: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2026-39466 · affects up to 2.4.7 · reported by PatchstackHigh 7.6
- Jun 2, 2025Broken Link Checker: Unauthorized data accessCVE-2025-4047 · affects up to 2.4.4 · reported by WordfenceMedium 4.3
- Dec 26, 2024Broken Link Checker: Does not validate a the link URLs before making a request to themCVE-2024-10903 · fixed in 2.4.2 · reported by WPScanMedium 4.7
- Sep 30, 2024Broken Link Checker: Reflected Cross-Site ScriptingCVE-2024-8981 · affects up to 2.4.0 · reported by WordfenceHigh 7.1
- Mar 15, 2024Broken Link Checker: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-25592 · affects up to 2.2.3 · reported by PatchstackMedium 5.9
- Jun 4, 2023A vulnerability was found in Broken Link Checker Plugin up to 1.10.1 on WordPress.CVE-2014-125105 · affects up to 1.10.1 · reported by VulDBLow 2.4
- Apr 8, 2023A vulnerability was found in Broken Link Checker Plugin up to 1.10.5 on WordPress.CVE-2015-10098 · affects up to 1.10.5 · reported by VulDBLow 3.5
- Dec 28, 2022Broken Link Checker: Does not sanitise and escape some of its settingsCVE-2022-3922 · fixed in 1.11.20 · reported by WPScanMedium 4.8
- Sep 6, 2022Broken Link Checker: Deserialization of untrusted inputCVE-2022-2438 · affects up to 1.11.16 · reported by Wordfence1.8% oddsHigh 7.2
- Oct 18, 2019A reflected XSS vulnerability was found in includes/admin/table-printer.php in the broken-link-checker (aka Broken Link Checker) plugin 1.11.8 for WordPress.CVE-2019-17207 · affects up to 1.11.8 · reported by MITRE1.6% oddsMedium 5.4
- Oct 16, 2019The broken-link-checker plugin through 1.11.8 for WordPress (aka Broken Link Checker) is susceptible to Reflected XSS due to improper encoding and insertion of CVE-2019-16521 · affects up to 1.11.8 · reported by MITRE1.4% oddsMedium 6.1
- Aug 18, 2017Cross-site scripting (XSS) vulnerability exists in the Wordpress admin panel when the Broken Link Checker plugin before 1.10.9 is installed.CVE-2015-5057 · fixed in 1.10.9 · reported by MITRE1.5% oddsMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.