WordPress plugin · breeze
Is Breeze Cache safe?
Safe on 2.6.3 or newer.
The current version, 2.6.3, is past every affected range on record (13 of 13 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 13
- High or critical
- 2
- Exploited
- none
- Current version
- 2.6.3
- Last updated
- Oct 20, 2026
- Active installs
- 300,000+
Every recorded flaw
- Sep 18, 2026Breeze Cache: Does not include a set of tracking-related query parameters in its page-cache key while still caching pages requested with themCVE-2026-79713 · fixed in 2.5.15 · reported by WPScanMedium 6.5
- Aug 28, 2026Breeze Cache: Does not sanitise a value taken from the request before using it to build the paths of the files it cachesCVE-2026-79706 · fixed in 2.5.13 · reported by WPScanMedium 5.3
- Aug 18, 2026Unauthenticated Arbitrary Content Deletion in Breeze <= 2.5.12 versions.CVE-2026-73356 · affects up to 2.5.12 · reported by PatchstackHigh 8.2
- Jul 13, 2026Breeze Cache: Is vulnerable to unauthenticated Stored Cross-Site Scripting (XSS) due to a predictable replacement hash used during the HTML minification process and abusing a regular expressionCVE-2026-10551 · fixed in 2.5.6 · reported by WPScanMedium 6.1
- May 29, 2026Breeze: Exposure of Sensitive Information to an Unauthorized ActorCVE-2026-2128 · affects up to 2.5.2 · reported by WordfenceMedium 5.3
- Apr 22, 2026Breeze Cache: Arbitrary file uploadsCVE-2026-3844 · affects up to 2.4.4 · reported by Wordfence28% oddsCritical 9.8
- Feb 19, 2026Breeze - WordPress Cache: Unauthorized cache clearingCVE-2025-13864 · affects up to 2.2.21 · reported by WordfenceMedium 5.3
- Jan 6, 2026Breeze: Missing AuthorizationCVE-2025-69364 · affects up to 2.2.21 · reported by PatchstackMedium 5.3
- Jun 18, 2025Breeze: Missing AuthorizationCVE-2025-23999 · affects up to 2.2.13 · reported by PatchstackMedium 4.3
- Oct 29, 2024Breeze: Missing AuthorizationCVE-2024-50422 · affects up to 2.1.14 · reported by PatchstackMedium 5.3
- Oct 28, 2024Breeze: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-50431 · affects up to 2.1.14 · reported by PatchstackMedium 5.9
- Mar 27, 2024Breeze: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-27188 · affects up to 2.1.3 · reported by PatchstackMedium 5.9
- May 2, 2022Cloudways Breeze plugin <= 2.0.2 on: Plugin Settings Change leading to Cross-Site Scripting (XSS)CVE-2022-29444 · affects up to 2.0.2 · reported by PatchstackMedium 6.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.