WordPress plugin · booster-elite-for-woocommerce
Is Booster Elite for WooCommerce safe?
Run 8.4.0 or newer.
3 flaws are on record. The newest fix on record is in 8.4.0.
- Flaws on record
- 3
- High or critical
- 0
- Exploited
- none
Every recorded flaw
- Oct 12, 2026Booster Elite for WooCommerce: Insertion of Sensitive Information Into Sent DataCVE-2023-25996 · fixed in 8.4.0 · reported by PatchstackMedium 6.5
- Jun 4, 2024Booster Elite for WooCommerce: Improper AuthenticationCVE-2023-51511 · fixed in 7.1.3 · reported by PatchstackMedium 6.5
- Mar 28, 2024Booster Elite for WooCommerce: Exposure of Sensitive Information to an Unauthorized ActorCVE-2023-52234 · fixed in 7.1.2 · reported by PatchstackMedium 6.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.