WordPress plugin · booking-package
Is Booking Package safe?
Safe on 1.7.36 or newer.
The current version, 1.7.36, is past every affected range on record (18 of 18 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 18
- High or critical
- 8
- Exploited
- none
- Current version
- 1.7.36
- Last updated
- Oct 27, 2026
- Active installs
- 10,000+
Every recorded flaw
- Oct 28, 2026Booking Package: Does not restrict who can trigger its booking verification-code emails nor bind the recipient to server-side stateCVE-2026-105997 · fixed in 1.7.33 · reported by WPScanMedium 5.3
- Oct 21, 2026Booking Package: Does not perform authorization checks before returning calendar-account configuration in a responseCVE-2026-105999 · fixed in 1.7.31 · reported by WPScanMedium 5.3
- Oct 21, 2026Booking Package: Does not perform any authorization or validity check before resetting its premium subscription stateCVE-2026-105998 · fixed in 1.7.31 · reported by WPScanMedium 5.3
- Oct 21, 2026Booking Package: Does not generate booking cancellation tokens using a secure source of randomnessCVE-2026-105996 · fixed in 1.7.31 · reported by WPScanMedium 4.8
- Oct 13, 2026Booking Package: Stored Cross-Site ScriptingCVE-2026-103425 · affects up to 1.7.29 · reported by WordfenceMedium 6.4
- Oct 13, 2026Booking Package: Authorization bypassCVE-2026-103423 · affects up to 1.7.29 · reported by WordfenceHigh 7.5
- Oct 10, 2026Booking Package: Does not perform authorization checks before returning stored reservation dataCVE-2026-105995 · fixed in 1.7.30 · reported by WPScanMedium 5.3
- Aug 26, 2026Booking Package: Does not validate the payment amount server-side against the stored service priceCVE-2026-16986 · fixed in 1.7.25 · reported by WPScanMedium 5.3
- Jul 11, 2026Booking Package: Generic SQL InjectionCVE-2026-15335 · affects up to 1.7.20 · reported by WordfenceHigh 7.5
- Jun 15, 2026Unauthenticated Broken Access Control in Booking Package <= 1.7.06 versions.CVE-2026-40774 · affects up to 1.7.06 · reported by PatchstackHigh 7.5
- Jun 6, 2026Booking Package: Privilege EscalationCVE-2026-9851 · affects up to 1.7.16 · reported by WordfenceHigh 7.2
- Apr 28, 2026Booking Package: Price ManipulationCVE-2026-4911 · affects up to 1.7.06 · reported by WordfenceMedium 5.3
- Jan 5, 2026Booking Package: Improper Validation of Specified Quantity in InputCVE-2024-30516 · affects up to 1.6.27 · reported by PatchstackHigh 7.5
- Feb 18, 2025Booking Package: Reflected Cross-Site ScriptingCVE-2024-13508 · affects up to 1.6.72 · reported by WordfenceMedium 6.1
- May 17, 2024Booking Package: Improper Privilege ManagementCVE-2023-37389 · affects up to 1.5.98 · reported by PatchstackHigh 8.8
- Sep 4, 2023Unauth.CVE-2023-39918 · fixed in 1.6.02 · reported by PatchstackHigh 7.1
- Apr 4, 2022Booking Package: Requires a token for exporting the ical representation of it's booking calendarCVE-2022-0709 · fixed in 1.5.29 · reported by WPScan1.6% oddsHigh 7.5
- Nov 24, 2021Booking Package - Appointment Booking Calendar System versions prior to 1.5.11: Cross-site scriptingCVE-2021-20840 · fixed in 1.5.11 · reported by vultures@jpcert.or.jp1.3% oddsMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.