WordPress plugin · blocksy-companion
Is Blocksy Companion safe?
Safe on 2.1.60 or newer.
The current version, 2.1.60, is past every affected range on record (15 of 15 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 15
- High or critical
- 4
- Exploited
- none
- Current version
- 2.1.60
- Last updated
- Oct 15, 2026
- Active installs
- 300,000+
Every recorded flaw
- Oct 10, 2026Blocksy Companion: Privilege escalationCVE-2026-107645 · affects up to 2.1.58 · reported by WordfenceCritical 9.1
- Sep 30, 2026Unauthenticated Broken Access Control in Blocksy Companion <= 2.1.55 versions.CVE-2026-97247 · affects up to 2.1.55 · reported by PatchstackMedium 6.5
- Sep 1, 2026Blocksy Companion: Stored Cross-Site ScriptingCVE-2026-18488 · affects up to 2.1.51 · reported by WordfenceMedium 6.4
- Jul 9, 2026Blocksy Companion: Arbitrary File UploadCVE-2026-15158 · affects up to 2.1.46 · reported by Wordfence1.1% oddsCritical 9.8
- Jul 8, 2026Blocksy Companion Pro: Unauthenticated arbitrary file uploadCVE-2026-58480 · fixed in 2.1.47 · reported by VulnCheck3.6% oddsCritical 9.2
- Jun 19, 2026Blocksy Companion: Stored Cross-Site ScriptingCVE-2026-12430 · affects up to 2.1.45 · reported by WordfenceMedium 4.4
- Nov 11, 2025Blocksy Companion: Authenticated arbitrary file uploadCVE-2025-12846 · affects up to 2.1.19 · reported by WordfenceHigh 8.8
- Oct 30, 2025Blocksy Companion: Stored Cross-Site ScriptingCVE-2025-12475 · affects up to 2.1.14 · reported by WordfenceMedium 6.4
- Sep 17, 2025Blocksy Companion: Stored Cross-Site ScriptingCVE-2025-9565 · affects up to 2.1.10 · reported by WordfenceMedium 6.4
- Jun 3, 2024Blocksy Companion: Server-Side Request Forgery (SSRF)CVE-2024-35633 · affects up to 2.0.42 · reported by PatchstackMedium 4.4
- May 14, 2024Blocksy Companion: Stored Cross-Site ScriptingCVE-2024-4487 · affects up to 2.0.45 · reported by WordfenceMedium 6.4
- Apr 11, 2024Blocksy Companion: Cross-Site Request Forgery (CSRF)CVE-2024-31932 · affects up to 2.0.28 · reported by PatchstackMedium 5.4
- Mar 21, 2024Blocksy Companion: Stored Cross-Site ScriptingCVE-2024-2392 · affects up to 2.0.31 · reported by WordfenceMedium 6.4
- May 2, 2023Blocksy Companion: Does not ensure that posts to be accessed via a shortcode are already public and can be viewedCVE-2023-1911 · fixed in 1.8.82 · reported by WPScanMedium 4.3
- Apr 6, 2023Auth.CVE-2023-23898 · fixed in 1.8.68 · reported by PatchstackMedium 5.5
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.