WordPress plugin · betterdocs
Is BetterDocs safe?
Safe on 4.9.5 or newer.
The current version, 4.9.5, is past every affected range on record (15 of 15 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 15
- High or critical
- 1
- Exploited
- none
- Current version
- 4.9.5
- Last updated
- Oct 12, 2026
- Active installs
- 30,000+
Every recorded flaw
- Sep 1, 2026BetterDocs – AI Documentation, Knowledge Base, Docs, Wikis, FAQ with Chatbot: Stored Cross-Site ScriptingCVE-2026-75980 · affects up to 4.8.1 · reported by WordfenceMedium 6.4
- Jul 27, 2026Contributor Cross Site Scripting (XSS) in BetterDocs <= 4.6.2 versions.CVE-2026-65562 · affects up to 4.6.2 · reported by PatchstackMedium 6.5
- Jul 16, 2026BetterDocs: Does not sanitise an AI-generated documentation summary before storing and outputting itCVE-2026-11371 · fixed in 4.5.5 · reported by WPScanMedium 6.1
- Jul 10, 2026BetterDocs – AI Documentation, Knowledge Base, Docs, Wikis, FAQ with Chatbot: Generic SQL InjectionCVE-2026-15104 · affects up to 4.6.0 · reported by WordfenceMedium 6.5
- Jun 19, 2026BetterDocs - Knowledge Base Docs & FAQ Solution for Elementor & Block Editor: Stored Cross-Site ScriptingCVE-2026-12157 · affects up to 4.5.3 · reported by WordfenceMedium 6.4
- Apr 29, 2026BetterDocs: Exposure of Sensitive System Information to an Unauthorized Control SphereCVE-2026-42644 · affects up to 4.3.10 · reported by PatchstackMedium 5.3
- Apr 24, 2026BetterDocs: Missing AuthorizationCVE-2026-6393 · affects up to 4.3.11 · reported by WordfenceMedium 4.3
- Apr 16, 2026BetterDocs: Stored Cross-Site ScriptingCVE-2026-3875 · affects up to 4.3.8 · reported by WordfenceMedium 6.4
- Jan 9, 2026BetterDocs: Sensitive Information ExposureCVE-2025-14980 · affects up to 4.3.3 · reported by WordfenceMedium 6.5
- Aug 16, 2025The BetterDocs – Advanced AI-Driven Documentation, FAQ & Knowledge Base Tool for Elementor & Gutenberg with Encyclopedia, AI Support, Instant Answers plugin forCVE-2025-7499 · affects up to 4.1.1 · reported by WordfenceMedium 5.3
- Dec 9, 2024BetterDocs: Missing AuthorizationCVE-2023-47762 · affects up to 2.5.2 · reported by PatchstackMedium 4.3
- Aug 13, 2024BetterDocs: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')CVE-2024-43129 · affects up to 3.5.8 · reported by PatchstackMedium 6.5
- Aug 12, 2024BetterDocs: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-43227 · affects up to 3.5.8 · reported by PatchstackMedium 6.5
- Apr 9, 2024BetterDocs – Best Documentation, FAQ & Knowledge Base Plugin with AI Support & Instant Answer For Elementor & Gutenberg: Stored Cross-Site ScriptingCVE-2024-2845 · affects up to 3.4.2 · reported by WordfenceMedium 6.4
- Mar 28, 2024BetterDocs: Deserialization of Untrusted DataCVE-2024-30226 · affects up to 3.3.3 · reported by PatchstackCritical 9
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.