WordPress plugin · asgaros-forum
Is Asgaros Forum safe?
Safe on 3.5.0 or newer.
The current version, 3.5.0, is past every affected range on record (13 of 13 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 13
- High or critical
- 6
- Exploited
- none
- Current version
- 3.5.0
- Last updated
- Oct 23, 2026
- Active installs
- 10,000+
Every recorded flaw
- Oct 9, 2026Asgaros Forum: Missing AuthorizationCVE-2026-39779 · affects up to 3.4.0 · reported by PatchstackMedium 4.3
- Nov 12, 2025Asgaros Forum: Cross-Site Request ForgeryCVE-2025-12901 · affects up to 3.2.1 · reported by WordfenceMedium 4.3
- Nov 7, 2025Asgaros Forum: SQL InjectionCVE-2025-11452 · affects up to 3.1.0 · reported by Wordfence1.6% oddsHigh 7.5
- Apr 16, 2025Asgaros Forum: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-39514 · affects up to 3.2.1 · reported by PatchstackMedium 6.5
- Apr 10, 2025Asgaros Forum: Authentication Bypass by SpoofingCVE-2025-32227 · affects up to 3.0.0 · reported by PatchstackMedium 4.3
- Apr 15, 2024Asgaros Forum: Cross-Site Request Forgery (CSRF)CVE-2024-32440 · affects up to 2.8.0 · reported by PatchstackMedium 4.3
- Jan 24, 2024Asgaros Forum: Deserialization of Untrusted DataCVE-2024-22284 · affects up to 2.7.2 · reported by PatchstackHigh 8.7
- Nov 27, 2023Asgaros Forum: Allows forum administratorsCVE-2023-5604 · fixed in 2.7.1 · reported by WPScan2.0% oddsCritical 9.8
- May 22, 2023Cross-Site Request Forgery (CSRF) vulnerability in Thomas Belser Asgaros Forum plugin <= 2.2.0 versions.CVE-2022-41608 · fixed in 2.3.0 · reported by PatchstackMedium 5.4
- Feb 28, 2022Asgaros Forum: Does not sanitise and escape the post_id parameter before using it in a SQL statement via a REST route of the plugin (accessible to any authenticated user)CVE-2022-0411 · fixed in 2.0.0 · reported by WPScan1.5% oddsHigh 8.8
- Jan 24, 2022Asgaros Forum: Does not validate or escape the forum_id parameter before using it in a SQL statementCVE-2021-25045 · fixed in 1.15.15 · reported by WPScan1.5% oddsHigh 7.2
- Nov 29, 2021Asgaros Forums: Stored Cross-Site ScriptingCVE-2021-42365 · affects up to 1.15.13 · reported by WordfenceMedium 4.8
- Nov 8, 2021Asgaros Forum: Does not validate and escape user inputCVE-2021-24827 · fixed in 1.15.13 · reported by WPScan13% oddsCritical 9.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.