WordPress plugin · arforms-form-builder
Is Contact Form, Survey, Quiz & Popup Form Builder safe?
Closed. Replace it.
wordpress.org closed it on Feb 1, 2025 (guideline violation), so it gets no more security fixes, and 11 flaws are on record. If your site runs it, move to a maintained alternative.
- Flaws on record
- 11
- High or critical
- 5
- Exploited
- none
Every recorded flaw
- Aug 16, 2026Contact Form, Survey, Quiz & Popup Form Builder – ARForms: PHP Object InjectionCVE-2024-13784 · affects up to 1.8.5 · reported by WordfenceCritical 9.8
- Mar 21, 2026The Contact Form, Survey, Quiz & Popup Form Builder – ARForms: Arbitrary shortcode executionCVE-2024-13785 · affects up to 1.7.2 · reported by WordfenceMedium 5.6
- May 15, 2025Contact Form, Survey, Quiz & Popup Form Builder: Does not sanitise and escape some parametersCVE-2024-10504 · fixed in 1.7.1 · reported by WPScanMedium 5.4
- Dec 9, 2024ARForms Form Builder: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)CVE-2024-54223 · affects up to 1.7.1 · reported by PatchstackMedium 5.3
- Jul 20, 2024ARForms Form Builder: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')CVE-2024-37920 · affects up to 1.6.7 · reported by PatchstackHigh 7.1
- May 8, 2024ARForms Form Builder: Missing AuthorizationCVE-2024-31270 · affects up to 1.6.1 · reported by PatchstackHigh 7.6
- May 2, 2024Contact Form, Survey & Popup Form Plugin for WordPress – ARForms Form Builder: Unauthorized loss of dataCVE-2024-1945 · affects up to 1.6.4 · reported by WordfenceHigh 7.1
- Apr 12, 2024ARForms Form Builder: Cross-Site Request Forgery (CSRF)CVE-2024-31272 · affects up to 1.6.1 · reported by PatchstackMedium 6.3
- Jan 11, 2024Contact Form, Survey & Popup Form Plugin for WordPress – ARForms Form Builder: Stored Cross-Site ScriptingCVE-2023-6828 · affects up to 1.5.8 · reported by WordfenceHigh 7.2
- Apr 18, 2023Unauth.CVE-2022-45838 · affects up to 1.5.5 · reported by PatchstackMedium 6.1
- Dec 6, 2021Contact Form, Survey & Popup Form Plugin for: Does not properly sanitize some of its settings allowing high privilege users to perform Cross-Site Scripting attacks evenCVE-2021-24718 · fixed in 1.5 · reported by WPScanMedium 4.8
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.