WordPress plugin · agile-store-locator
Is Agile Store Locator safe?
Safe on 1.8.9 or newer.
The current version, 1.8.9, is past every affected range on record (11 of 11 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 11
- High or critical
- 2
- Exploited
- none
- Current version
- 1.8.9
- Last updated
- Oct 21, 2026
- Active installs
- 10,000+
Every recorded flaw
- Jun 13, 2026Store Locator: Does not validate a parameter before using it in a file pathCVE-2026-9062 · fixed in 1.6.9 · reported by WPScanLow 3.4
- Jun 13, 2026Store Locator: Does not sanitize and escape store logo metadata before storing it and outputting it on the Store Locator WordPress plugin before 1CVE-2026-9061 · fixed in 1.6.9 · reported by WPScanLow 3.5
- Jun 10, 2026Store Locator: Does not sanitize and escape one of its settings before storing it and outputting it on the Store Locator WordPress plugin before 1CVE-2026-9060 · fixed in 1.6.6 · reported by WPScanLow 3.5
- Dec 9, 2025Store Locator: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2025-67516 · affects up to 1.6.2 · reported by PatchstackHigh 8.5
- Jun 6, 2025Store Locator: Unrestricted Upload of File with Dangerous TypeCVE-2025-49329 · affects up to 1.5.2 · reported by PatchstackMedium 6.6
- Jun 6, 2025Store Locator: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2025-49328 · affects up to 1.5.1 · reported by PatchstackHigh 7.6
- Apr 18, 2024Store Locator: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')CVE-2023-50885 · affects up to 1.4.14 · reported by PatchstackMedium 6.8
- Sep 4, 2023Store Locator: Does not sanitise and escape an invalid nonce before outputting it back in an AJAX responseCVE-2023-4151 · fixed in 1.4.13 · reported by WPScanMedium 6.1
- Jun 22, 2023Auth.CVE-2023-27618 · affects up to 1.4.9 · reported by PatchstackMedium 5.9
- Jan 23, 2023Store Locator: Does not validate and escape some of its shortcode attributes before outputting them back in the pageCVE-2022-4832 · fixed in 1.4.9 · reported by WPScanMedium 5.4
- Nov 18, 2022Cross-Site Scripting (XSS) via Cross-Site Request Forgery (CSRF) vulnerability in Store Locator plugin <= 1.4.5 on WordPress.CVE-2022-41615 · affects up to 1.4.5 · reported by PatchstackMedium 6.1
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.