WordPress plugin · advanced-form-integration
Is Advanced Form Integration safe?
Safe on 2.11.0 or newer.
The current version, 2.11.0, is past every affected range on record (10 of 10 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 3
- Exploited
- none
- Current version
- 2.11.0
- Last updated
- Oct 25, 2026
- Active installs
- 9,000+
Every recorded flaw
- Oct 10, 2026Advanced Form Integration — Connect Forms to 300+ Apps: Authentication BypassCVE-2026-104797 · affects up to 2.9.0 · reported by WordfenceHigh 8.1
- Jul 28, 2026Advanced Form Integration — Connect Forms to 200+ Apps: Authorization bypassCVE-2026-16587 · affects up to 2.6.0 · reported by WordfenceMedium 4.3
- Jul 1, 2026Advanced Form Integration — Connect Forms to 200+ Apps: Does not restrict the WordPress role assignedCVE-2026-11794 · fixed in 2.1.1 · reported by WPScanHigh 8.1
- Jun 15, 2026Subscriber Broken Access Control in Advanced Form Integration <= 1.126.12 versions.CVE-2026-42659 · affects up to 1.126.12 · reported by PatchstackMedium 6.5
- Jan 7, 2025Advanced Form Integration: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-56293 · affects up to 1.95.0 · reported by PatchstackMedium 5.9
- Nov 13, 2024AFI – The Easiest Integration: Reflected Cross-Site ScriptingCVE-2024-10877 · affects up to 1.92.0 · reported by WordfenceMedium 6.1
- Aug 26, 2024Advanced Form Integration: Cross-Site Request Forgery (CSRF)CVE-2024-43340 · affects up to 1.89.4 · reported by PatchstackMedium 4.3
- Mar 19, 2024Advanced Form Integration – Connect WooCommerce and Contact Form 7 to Google Sheets and other platforms: SQL InjectionCVE-2024-2387 · affects up to 1.82.0 · reported by Wordfence1.6% oddsMedium 6.1
- Dec 28, 2023Advanced Form Integration – Connect WooCommerce and Contact Form 7 to Google Sheets and other platforms: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')CVE-2023-50853 · affects up to 1.75.0 · reported by PatchstackHigh 7.6
- Mar 23, 2023Auth.CVE-2022-47173 · fixed in 1.63.0 · reported by PatchstackMedium 5.9
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.