WordPress plugin · advanced-access-manager
Is Access Governance for WordPress (aka AAM) safe?
Safe on 8.0.2 or newer.
The current version, 8.0.2, is past every affected range on record (10 of 10 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 10
- High or critical
- 4
- Exploited
- none
- Current version
- 8.0.2
- Last updated
- Oct 19, 2026
- Active installs
- 100,000+
Every recorded flaw
- Jun 1, 2026Advanced Access Manager: Authentication Bypass by SpoofingCVE-2026-42674 · affects up to 7.1.0 · reported by PatchstackHigh 7.5
- Oct 16, 2024Advanced Access Manager: Unauthenticated Arbitrary File ReadCVE-2019-25213 · affects up to 5.9.8.1 · reported by Wordfence2.8% oddsCritical 9.8
- Mar 19, 2024Advanced Access Manager: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-29124 · affects up to 6.9.20 · reported by PatchstackMedium 5.9
- Mar 19, 2024Advanced Access Manager: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-29127 · affects up to 6.9.20 · reported by PatchstackHigh 7.1
- Feb 1, 2024Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2023-51674 · affects up to 6.9.18 · reported by PatchstackMedium 6.5
- Dec 29, 2023Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More: URL Redirection to Untrusted Site ('Open Redirect')CVE-2023-51675 · affects up to 6.9.18 · reported by PatchstackMedium 4.7
- Dec 29, 2023Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2023-50881 · affects up to 6.9.15 · reported by PatchstackMedium 6.5
- Nov 23, 2021Advanced Access Manager: Does not escape some of its settingsCVE-2021-24830 · fixed in 6.8.0 · reported by WPScanMedium 4.8
- Dec 31, 2020The Advanced Access Manager plugin before 6.6.2 for WordPress allows privilege escalation on profile updates via the aam_user_roles POST parameter if Multiple RCVE-2020-35935 · fixed in 6.6.2 · reported by MITRE1.5% oddsHigh 7.5
- Dec 31, 2020The Advanced Access Manager plugin before 6.6.2 for WordPress displays the unfiltered user object (including all metadata) upon login via the REST API (aam/v1/aCVE-2020-35934 · fixed in 6.6.2 · reported by MITRE1.1% oddsMedium 4.3
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.