WordPress plugin · addon-elements-for-elementor-page-builder
Is Addon Elements for Elementor (formerly Elementor Addon Elements) safe?
Safe on 1.15 or newer.
The current version, 1.15, is past every affected range on record (28 of 28 records list one). Keep it updated and you’re clear of them.
- Flaws on record
- 28
- High or critical
- 1
- Exploited
- none
- Current version
- 1.15
- Last updated
- Oct 22, 2026
- Active installs
- 80,000+
Every recorded flaw
- Oct 22, 2026Elementor Addon Elements: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2026-114184 · affects up to 1.14.4 · reported by PatchstackMedium 6.5
- Feb 26, 2026Elementor Addon Elements: Insertion of Sensitive Information Into Sent DataCVE-2026-28131 · affects up to 1.14.4 · reported by PatchstackMedium 6.5
- Dec 14, 2025Addon Elements for Elementor: Stored Cross-Site ScriptingCVE-2025-12537 · affects up to 1.14.3 · reported by WordfenceMedium 6.4
- Jan 15, 2025Elementor Addon Elements: Sensitive Information ExposureCVE-2024-13215 · affects up to 1.13.10 · reported by WordfenceMedium 4.3
- Nov 1, 2024Elementor Addon Elements: Missing AuthorizationCVE-2024-47361 · affects up to 1.13.6 · reported by PatchstackMedium 6.5
- Oct 12, 2024Elementor Addon Elements: Sensitive Information ExposureCVE-2024-8902 · affects up to 1.13.8 · reported by WordfenceMedium 4.3
- Oct 6, 2024Elementor Addon Elements: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-47366 · affects up to 1.13.6 · reported by PatchstackMedium 6.5
- Aug 30, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-7122 · affects up to 1.13.6 · reported by WordfenceMedium 6.4
- Aug 30, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-4401 · affects up to 1.13.5 · reported by WordfenceMedium 6.4
- Jun 27, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-4570 · affects up to 1.13.5 · reported by WordfenceMedium 6.4
- Jun 27, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-4569 · affects up to 1.13.5 · reported by WordfenceMedium 6.4
- Jun 12, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-2092 · affects up to 1.13.3 · reported by WordfenceMedium 5.4
- May 2, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-3743 · affects up to 1.13.3 · reported by WordfenceMedium 6.4
- Apr 9, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-2792 · affects up to 1.13.2 · reported by WordfenceMedium 6.4
- Mar 28, 2024Elementor Addon Elements: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-30422 · affects up to 1.13.1 · reported by PatchstackMedium 6.5
- Mar 27, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-2091 · affects up to 1.13.2 · reported by WordfenceMedium 5.4
- Mar 19, 2024Elementor Addon Elements: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-29107 · affects up to 1.12.10 · reported by PatchstackMedium 6.5
- Mar 13, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-1422 · affects up to 1.12.12 · reported by WordfenceMedium 6.4
- Mar 13, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-1393 · affects up to 1.12.12 · reported by WordfenceMedium 6.4
- Mar 13, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-1392 · affects up to 1.12.12 · reported by WordfenceMedium 6.4
- Mar 13, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-1391 · affects up to 1.12.12 · reported by WordfenceMedium 6.4
- Mar 13, 2024Elementor Addon Elements: Directory TraversalCVE-2024-1358 · affects up to 1.12.12 · reported by Wordfence1.2% oddsHigh 8.8
- Feb 5, 2024Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2024-0834 · affects up to 1.12.11 · reported by WordfenceMedium 6.4
- Nov 15, 2023Elementor Addon Elements: Stored Cross-Site ScriptingCVE-2023-5381 · affects up to 1.12.7 · reported by WordfenceMedium 4.4
- Nov 15, 2023Elementor Addon Elements: Sensitive Information ExposureCVE-2023-4723 · affects up to 1.12.7 · reported by WordfenceMedium 5.3
- Nov 15, 2023Elementor Addon Elements: Cross-Site Request ForgeryCVE-2023-4690 · affects up to 1.12.7 · reported by WordfenceMedium 5.4
- Nov 15, 2023Elementor Addon Elements: Cross-Site Request ForgeryCVE-2023-4689 · affects up to 1.12.7 · reported by WordfenceMedium 5.4
- May 5, 2021Elementor Addon Elements: Has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users suchCVE-2021-24259 · fixed in 1.11.2 · reported by WPScanMedium 5.4
Records come from the National Vulnerability Database, published by the researchers who found each flaw (Wordfence, Patchstack, WPScan and others); exploited status from CISA; exploit odds from FIRST’s EPSS; current version, installs and closures from wordpress.org, checked daily. Want every plugin on your site checked at once? Run the free website check.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.