Vulnerability database
Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.
4 results
Mar 20, 2025In yiisoft/yii2 version 2.0.48, the base Component class contains a vulnerability where the `__set()` magic method does not validate that the value passed is a CVE-2024-4990 · Websites & servers · yiisoft · reported by security@huntr.devCritical 9.1
In yiisoft/yii2 version 2.0.48, the base Component class contains a vulnerability where the `__set()` magic method does not validate that the value passed is a valid Behavior class name or configuration. This allows an attacker to instantiate arbitrary classes, passing parameters to their constructors and invoking setter methods. Depending on the installed dependencies, various types of attacks are possible, including the execution of arbitrary code, retrieval of sensitive information, and unauthorized access.
- Product
- yiisoft/yii2
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Aug 10, 2021yii2 is vulnerable to Use of Predictable Algorithm in Random Number GeneratorCVE-2021-3692 · Websites & servers · yiisoft · reported by security@huntr.devMedium 5.3
yii2 is vulnerable to Use of Predictable Algorithm in Random Number Generator
- Product
- yiisoft/yii2
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Aug 10, 2021yii2 is vulnerable to Use of Predictable Algorithm in Random Number GeneratorCVE-2021-3689 · Websites & servers · yiisoft · reported by security@huntr.devHigh 7.5
yii2 is vulnerable to Use of Predictable Algorithm in Random Number Generator
- Product
- yiisoft/yii2
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Sep 15, 2020Yii 2 (yiisoft/yii2) before version 2.0.38 is vulnerable to remote code execution if the application calls `unserialize()` on arbitrary user input.CVE-2020-15148 · Other software · yiisoft · reported by GitHubHigh 8.9
Yii 2 (yiisoft/yii2) before version 2.0.38 is vulnerable to remote code execution if the application calls `unserialize()` on arbitrary user input. This is fixed in version 2.0.38. A possible workaround without upgrading is available in the linked advisory.
- Product
- yii2
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.