Vulnerability database
Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.
4 results
Sep 26, 2024LayUI is a native minimalist modular Web UI component library.CVE-2024-47075 · Other software · layui · reported by GitHubMedium 6.4
LayUI is a native minimalist modular Web UI component library. Versions prior to 2.9.17 have a DOM Clobbering vulnerability that can lead to Cross-site Scripting (XSS) on web pages where attacker-controlled HTML elements (e.g., `img` tags with unsanitized `name` attributes) are present. Version 2.9.17 fixes this issue.
- Product
- layui
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Dec 30, 2023layui up to v2.74 was discovered to contain a cross-site scripting (XSS) vulnerability via the data-content parameter.CVE-2023-50550 · Other software · Layui · reported by MITREMedium 5.4
layui up to v2.74 was discovered to contain a cross-site scripting (XSS) vulnerability via the data-content parameter.
- Product
- Layui
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Jul 16, 2023A vulnerability, which was classified as problematic, was found in layui up to v2.8.0-rc.16.CVE-2023-3691 · Other software · Layui · reported by VulDBLow 3.5
A vulnerability, which was classified as problematic, was found in layui up to v2.8.0-rc.16. This affects an unknown part of the component HTML Attribute Handler. The manipulation of the argument title leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.8.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-234237 was assigned to this vulnerability.
- Product
- Layui
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Dec 27, 2020CXUUCMS V3 allows class="layui-input" XSS.CVE-2020-29249 · Other software · Cxuu · reported by MITREMedium 6.1
CXUUCMS V3 allows class="layui-input" XSS.
- Product
- Cxuucms
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.