Vulnerability database
Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.
3 results
Oct 28, 2026decode-uri-component provides a more robust alternative to decodeURIComponent.CVE-2026-118664 · Other software · SamVerschueren · reported by GitHubHigh 8.2
decode-uri-component provides a more robust alternative to decodeURIComponent. Prior to 0.5.1, decodeUriComponent in index.js falls back to customDecodeURIComponent after native decoding throws, and the fallback collects every distinct percent-encoded run before performing a full-string regular-expression replacement for each entry. Malformed input containing many distinct runs can therefore make both the number of replacements and the scanned input length grow together, causing quadratic CPU consumption and blocking the Node.js event loop; request-body inputs can reach the demonstrated size, while ordinary URL header limits reduce the practical delay. This issue is fixed in version 0.5.1.
- Product
- decode-uri-component
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Jun 30, 2026decode-uri-component through 0.4.1 is vulnerable to denial of service.CVE-2026-45822 · Other software · SamVerschueren · reported by 22e2d327-25fe-45d7-9f0c-dcd23b7108dfMedium 6.6
decode-uri-component through 0.4.1 is vulnerable to denial of service. The decode() function splits input on '%' producing N tokens and calls decodeComponents(), exhibiting super-linear parsing time: 200 '%ab' tokens takes approximately 0.7s, 700 tokens approximately 6s, and 1400 tokens approximately 33s. An attacker can cause significant CPU consumption and event-loop blocking via crafted input.
- Product
- decode-uri-component
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Nov 28, 2022decode-uri-component 0.2.0 is vulnerable to Improper Input Validation resulting in DoS.CVE-2022-38900 · Other software · Decode-uri-component Project · reported by MITREHigh 7.5
decode-uri-component 0.2.0 is vulnerable to Improper Input Validation resulting in DoS.
- Product
- Decode-uri-component
- What to do
- Apply the vendor’s update. The NVD record links to the advisory.
Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.