Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies
Updated 9 h ago

Vulnerability database

Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.

1,764exploited flaws on CISA’s list
35added in the last 30 days
456new WordPress flaws this week
390,714entries in the database

7 results

  • Jun 12, 2021It was discovered that the process_report() function in data/whoopsie-upload-all allowed arbitrary file writes via symlinks.CVE-2021-32557 · Other software · Canonical · reported by security@ubuntu.comMedium 5.2

    It was discovered that the process_report() function in data/whoopsie-upload-all allowed arbitrary file writes via symlinks.

    Product
    apport
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Aug 6, 2020In whoopsie, parse_report() from whoopsie.c allows a local attacker to cause a denial of service via a crafted file.CVE-2020-11937 · Other software · Canonical · reported by security@ubuntu.comMedium 5.5

    In whoopsie, parse_report() from whoopsie.c allows a local attacker to cause a denial of service via a crafted file. The DoS is caused by resource exhaustion due to a memory leak. Fixed in 0.2.52.5ubuntu0.5, 0.2.62ubuntu0.5 and 0.2.69ubuntu0.1.

    Product
    whoopsie
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Jul 6, 2020The parse_report() function in whoopsie.c in Whoopsie through 0.2.69 mishandles memory allocation failures, which allows an attacker to cause a denial of servicCVE-2020-15570 · Other software · Whoopsie Project · reported by MITREMedium 5.5

    The parse_report() function in whoopsie.c in Whoopsie through 0.2.69 mishandles memory allocation failures, which allows an attacker to cause a denial of service via a malformed crash file.

    Product
    Whoopsie
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Apr 23, 2020bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and return values.CVE-2020-12135 · Other software · Whoopsie Project · reported by MITREMedium 5.5

    bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and return values. In particular, the bson_ensure_space() parameter bytesNeeded could have an integer overflow via properly constructed bson input.

    Product
    Whoopsie
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Feb 8, 2020Kevin Backhouse discovered an integer overflow in bson_ensure_space, as used in whoopsie.CVE-2019-11484 · Other software · Canonical · reported by security@ubuntu.comMedium 6.3

    Kevin Backhouse discovered an integer overflow in bson_ensure_space, as used in whoopsie.

    Product
    whoopsie
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Jan 15, 2020whoopsie-daisy before 0.1.26: Root user can remove arbitrary filesCVE-2012-0945 · Other software · whoopsie-daisy · reported by security@ubuntu.comMedium 4.9

    whoopsie-daisy before 0.1.26: Root user can remove arbitrary files

    Product
    whoopsie-daisy
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Aug 29, 2019An integer overflow in whoopsie before versions 0.2.52.5ubuntu0.1, 0.2.62ubuntu0.1, 0.2.64ubuntu0.1, 0.2.66, results in an out-of-bounds write to a heap allocatCVE-2019-11476 · Other software · Ubuntu · reported by security@ubuntu.comMedium 6.5

    An integer overflow in whoopsie before versions 0.2.52.5ubuntu0.1, 0.2.62ubuntu0.1, 0.2.64ubuntu0.1, 0.2.66, results in an out-of-bounds write to a heap allocated buffer when processing large crash dumps. This results in a crash or possible code-execution in the context of the whoopsie process.

    Product
    Whoopsie
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.

Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.

Weekly security brief

The flaws that hit local websites, every Friday.

One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.