Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies
Updated 5 h ago

Vulnerability database

Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.

1,762exploited flaws on CISA’s list
34added in the last 30 days
344new WordPress flaws this week
390,080entries in the database

9 results

  • Apr 5, 2022CRHTLF can lead to invalid protocol extraction potentially leading to XSS in GitHub repository medialize/uri.js prior to 1.19.11.CVE-2022-1243 · Other software · medialize · reported by security@huntr.devMedium 6.1

    CRHTLF can lead to invalid protocol extraction potentially leading to XSS in GitHub repository medialize/uri.js prior to 1.19.11.

    Product
    medialize/uri.js
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Apr 4, 2022URL Confusion When Scheme Not Supplied in GitHub repository medialize/uri.js prior to 1.19.11.CVE-2022-1233 · Other software · medialize · reported by security@huntr.devMedium 6.1

    URL Confusion When Scheme Not Supplied in GitHub repository medialize/uri.js prior to 1.19.11.

    Product
    medialize/uri.js
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Mar 6, 2022Open Redirect in GitHub repository medialize/uri.js prior to 1.19.10.CVE-2022-0868 · Other software · medialize · reported by security@huntr.devMedium 6.1

    Open Redirect in GitHub repository medialize/uri.js prior to 1.19.10.

    Product
    medialize/uri.js
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Mar 3, 2022URI.js is a Javascript URL mutation library.CVE-2022-24723 · Other software · medialize · reported by GitHubMedium 5.3

    URI.js is a Javascript URL mutation library. Before version 1.19.9, whitespace characters are not removed from the beginning of the protocol, so URLs are not parsed properly. This issue has been patched in version 1.19.9. Removing leading whitespace from values before passing them to URI.parse can be used as a workaround.

    Product
    URI.js
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Feb 16, 2022Authorization Bypass Through User-Controlled Key in NPM urijs prior to 1.19.8.CVE-2022-0613 · Other software · medialize · reported by security@huntr.devMedium 6.5

    Authorization Bypass Through User-Controlled Key in NPM urijs prior to 1.19.8.

    Product
    medialize/uri.js
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Jul 16, 2021URI.js is vulnerable to URL Redirection to Untrusted SiteCVE-2021-3647 · Other software · medialize · reported by security@huntr.devMedium 6.1

    URI.js is vulnerable to URL Redirection to Untrusted Site

    Product
    medialize/URI.js
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Feb 21, 2021URI.js (aka urijs) before 1.19.6 mishandles certain uses of backslash such as http:\/ and interprets the URI as a relative path.CVE-2021-27516 · Other software · Uri.js Project · reported by MITREHigh 7.5

    URI.js (aka urijs) before 1.19.6 mishandles certain uses of backslash such as http:\/ and interprets the URI as a relative path.

    Product
    Uri.js
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Dec 30, 2020URI.js is a javascript URL mutation library (npm package urijs).CVE-2020-26291 · Other software · medialize · reported by GitHubMedium 6.5

    URI.js is a javascript URL mutation library (npm package urijs). In URI.js before version 1.19.4, the hostname can be spoofed by using a backslash (`\`) character followed by an at (`@`) character. If the hostname is used in security decisions, the decision may be incorrect. Depending on library usage and attacker intent, impacts may include allow/block list bypasses, SSRF attacks, open redirects, or other undesired behavior. For example the URL `https://expected-example.com\@observed-example.com` will incorrectly return `observed-example.com` if using an affected version. Patched versions correctly return `expected-example.com`. Patched versions match the behavior of other parsers which implement the WHATWG URL specification, including web browsers and Node's built-in URL class. Version 1.19.4 is patched against all known payload variants. Version 1.19.3 has a partial patch but is still vulnerable to a payload variant.]

    Product
    URI.js
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Jun 5, 2016uri.js in Google V8 before 5.1.281.26, as used in Google Chrome before 51.0.2704.63, uses an incorrect array type, which allows remote attackers to obtain sensiCVE-2016-1677 · Computers, phones & browsers · Google · reported by chrome-cve-admin@google.comMedium 6.5

    uri.js in Google V8 before 5.1.281.26, as used in Google Chrome before 51.0.2704.63, uses an incorrect array type, which allows remote attackers to obtain sensitive information by calling the decodeURI function and leveraging "type confusion."

    Product
    Chrome
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.

Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.

Weekly security brief

The flaws that hit local websites, every Friday.

One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.