Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies
Updated 4 h ago

Vulnerability database

Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.

1,762exploited flaws on CISA’s list
34added in the last 30 days
344new WordPress flaws this week
390,080entries in the database

7 results

  • Apr 23, 2025PostHog database_schema Server-Side Request Forgery Information Disclosure Vulnerability.CVE-2025-1522 · Other software · PostHog · reported by zdi-disclosures@trendmicro.comMedium 6.5

    PostHog database_schema Server-Side Request Forgery Information Disclosure Vulnerability. This vulnerability allows remote attackers to disclose sensitive information on affected installations of PostHog. Authentication is required to exploit this vulnerability. The specific flaw exists within the implementation of the database_schema method. The issue results from the lack of proper validation of a URI prior to accessing resources. An attacker can leverage this vulnerability to disclose information in the context of the service account. Was ZDI-CAN-25358.

    Product
    PostHog
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Apr 23, 2025PostHog slack_incoming_webhook Server-Side Request Forgery Information Disclosure Vulnerability.CVE-2025-1521 · Other software · PostHog · reported by zdi-disclosures@trendmicro.comMedium 6.5

    PostHog slack_incoming_webhook Server-Side Request Forgery Information Disclosure Vulnerability. This vulnerability allows remote attackers to disclose sensitive information on affected installations of PostHog. Authentication is required to exploit this vulnerability. The specific flaw exists within the processing of the slack_incoming_webhook parameter. The issue results from the lack of proper validation of a URI prior to accessing resources. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-25352.

    Product
    PostHog
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Apr 23, 2025PostHog ClickHouse Table Functions SQL Injection Remote Code Execution Vulnerability.CVE-2025-1520 · Other software · PostHog · reported by zdi-disclosures@trendmicro.comHigh 8

    PostHog ClickHouse Table Functions SQL Injection Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of PostHog. Authentication is required to exploit this vulnerability. The specific flaw exists within the implementation of the SQL parser. The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to execute code in the context of the database account. Was ZDI-CAN-25350.

    Product
    PostHog
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Nov 22, 2024PostHog database_schema Server-Side Request Forgery Information Disclosure Vulnerability.CVE-2024-9710 · Other software · PostHog · reported by zdi-disclosures@trendmicro.comHigh 8.3

    PostHog database_schema Server-Side Request Forgery Information Disclosure Vulnerability. This vulnerability allows remote attackers to disclose sensitive information on affected installations of PostHog. Authentication is required to exploit this vulnerability. The specific flaw exists within the implementation of the database_schema method. The issue results from the lack of proper validation of a URI prior to accessing resources. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-25351.

    Product
    PostHog
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Dec 1, 2023PostHog provides open-source product analytics, session recording, feature flagging and A/B testing that you can self-host.CVE-2023-46746 · Other software · PostHog · reported by GitHubMedium 4.8

    PostHog provides open-source product analytics, session recording, feature flagging and A/B testing that you can self-host. A server-side request forgery (SSRF), which can only be exploited by authenticated users, was found in Posthog. Posthog did not verify whether a URL was local when enabling webhooks, allowing authenticated users to forge a POST request. This vulnerability has been addressed in `22bd5942` and will be included in subsequent releases. There are no known workarounds for this vulnerability.

    Product
    posthog
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • May 26, 2023PostHog-js is a library to interface with the PostHog analytics tool.CVE-2023-32325 · Other software · PostHog · reported by GitHubMedium 5.4

    PostHog-js is a library to interface with the PostHog analytics tool. Versions prior to 1.57.2 have the potential for cross-site scripting. Problem has been patched in 1.57.2. Users are advised to upgrade. Users unable to upgrade should ensure that their Content Security Policy is in place.

    Product
    posthog-js
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Apr 19, 2022Open redirect vulnerability via endpoint authorize_and_redirect/?redirect= in GitHub repository posthog/posthog prior to 1.34.1.CVE-2022-0645 · Other software · posthog · reported by security@huntr.devMedium 6.1

    Open redirect vulnerability via endpoint authorize_and_redirect/?redirect= in GitHub repository posthog/posthog prior to 1.34.1.

    Product
    posthog/posthog
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.

Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.

Weekly security brief

The flaws that hit local websites, every Friday.

One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.