Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies
Updated 12 h ago

Vulnerability database

Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.

1,762exploited flaws on CISA’s list
34added in the last 30 days
343new WordPress flaws this week
390,080entries in the database

9 results

  • Jun 1, 2026A weakness has been identified in janet-lang janet up to 1.41.0.CVE-2026-10268 · Other software · janet-lang · reported by VulDBLow 1.9

    A weakness has been identified in janet-lang janet up to 1.41.0. This vulnerability affects the function unmarshal_one_fiber of the file src/core/marsh.c. Executing a manipulation can lead to integer overflow. It is possible to launch the attack on the local host. The exploit has been made available to the public and could be used for attacks. This patch is called d9b1d711ea1fde52ac73a82088b512a3e17bad0d. A patch should be applied to remediate this issue.

    Product
    janet
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Jun 1, 2026A security flaw has been discovered in janet-lang janet up to 1.41.0.CVE-2026-10267 · Other software · janet-lang · reported by VulDBLow 1.9

    A security flaw has been discovered in janet-lang janet up to 1.41.0. This affects the function doframe of the file src/core/debug.c. Performing a manipulation results in out-of-bounds read. Attacking locally is a requirement. The exploit has been released to the public and may be used for attacks. The patch is named ed17dd2c5913a23fb1107251e44a9410a3c30cf5.

    Product
    janet
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Feb 21, 2026A vulnerability was identified in janet-lang janet up to 1.40.1.CVE-2026-2869 · Other software · janet-lang · reported by VulDBLow 1.9

    A vulnerability was identified in janet-lang janet up to 1.40.1. Affected by this vulnerability is the function janetc_varset of the file src/core/specials.c of the component handleattr Handler. The manipulation leads to out-of-bounds read. The attack can only be performed from a local environment. The exploit is publicly available and might be used. Upgrading to version 1.41.0 addresses this issue. The identifier of the patch is 2fabc80151a2b8834ee59cda8a70453f848b40e5. The affected component should be upgraded.

    Product
    janet
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Feb 9, 2026A vulnerability was determined in janet-lang janet up to 1.40.1.CVE-2026-2242 · Other software · janet-lang · reported by VulDBLow 1.9

    A vulnerability was determined in janet-lang janet up to 1.40.1. This impacts the function janetc_if of the file src/core/specials.c. Executing a manipulation can lead to out-of-bounds read. The attack needs to be launched locally. The exploit has been publicly disclosed and may be utilized. This patch is called c43e06672cd9dacf2122c99f362120a17c34b391. It is advisable to implement a patch to correct this issue.

    Product
    janet
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Feb 9, 2026A vulnerability was found in janet-lang janet up to 1.40.1.CVE-2026-2241 · Other software · janet-lang · reported by VulDBLow 1.9

    A vulnerability was found in janet-lang janet up to 1.40.1. This affects the function os_strftime of the file src/core/os.c. Performing a manipulation results in out-of-bounds read. The attack must be initiated from a local position. The exploit has been made public and could be used. The patch is named 0f285855f0e34f9183956be5f16e045f54626bff. To fix this issue, it is recommended to deploy a patch.

    Product
    janet
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Feb 9, 2026A vulnerability has been found in janet-lang janet up to 1.40.1.CVE-2026-2240 · Other software · janet-lang · reported by VulDBLow 1.9

    A vulnerability has been found in janet-lang janet up to 1.40.1. The impacted element is the function janetc_pop_funcdef of the file src/core/compile.c. Such manipulation leads to out-of-bounds read. The attack must be carried out locally. The exploit has been disclosed to the public and may be used. The name of the patch is 4dd08a4cdef5b1c42d9a2c19fc24412e97ef51d5. A patch should be applied to remediate this issue.

    Product
    janet
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • May 15, 2022Janet before 1.22.0 mishandles arrays.CVE-2022-30763 · Other software · Janet-lang · reported by MITREHigh 7.5

    Janet before 1.22.0 mishandles arrays.

    Product
    Janet
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Mar 19, 2012Multiple cross-site request forgery (CSRF) vulnerabilities in Janetter before 3.3.0.0 (aka 3.3.0) allow remote attackers to hijack the authentication of arbitraCVE-2012-1236 · Other software · Janetter · reported by vultures@jpcert.or.jpMedium 6.8

    Multiple cross-site request forgery (CSRF) vulnerabilities in Janetter before 3.3.0.0 (aka 3.3.0) allow remote attackers to hijack the authentication of arbitrary users for requests that (1) tweet, (2) upload an image file, or (3) execute arbitrary commands.

    Product
    Janetter
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Mar 19, 2012Janetter before 3.3.0.0 (aka 3.3.0) allows remote attackers to obtain session information for twitter.com web sites via unspecified vectors.CVE-2012-0328 · Other software · Janetter · reported by vultures@jpcert.or.jpMedium 5

    Janetter before 3.3.0.0 (aka 3.3.0) allows remote attackers to obtain session information for twitter.com web sites via unspecified vectors.

    Product
    Janetter
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.

Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.

Weekly security brief

The flaws that hit local websites, every Friday.

One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.