Vulnerability database
Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.
4 results
Sep 22, 2025Fastly: Cross-Site Request Forgery (CSRF)CVE-2025-58199 · WordPress plugins & themes · reported by PatchstackMedium 4.3
Cross-Site Request Forgery (CSRF) vulnerability in Fastly Fastly fastly allows Cross Site Request Forgery.This issue affects Fastly: from n/a through <= 1.2.28.
- Product
- Fastly
- Affected
- up to 1.2.28
- What to do
- Affects up to 1.2.28. Update Fastly to the newest version and check its changelog mentions this fix; if there isn’t one yet, deactivate it until there is.
Jun 11, 2024Fastly: Missing AuthorizationCVE-2024-34768 · WordPress plugins & themes · reported by PatchstackMedium 5.3
Missing Authorization vulnerability in Fastly.This issue affects Fastly: from n/a through 1.2.25.
- Product
- Fastly
- Affected
- up to 1.2.25
- What to do
- Affects up to 1.2.25. Update Fastly to the newest version and check its changelog mentions this fix; if there isn’t one yet, deactivate it until there is.
Full record and what to do →NVD recordpatchstack.compatchstack.com
Jun 3, 2024Fastly: Missing AuthorizationCVE-2024-34803 · WordPress plugins & themes · reported by PatchstackMedium 4.3
Missing Authorization vulnerability in Fastly.This issue affects Fastly: from n/a through 1.2.25.
- Product
- Fastly
- Affected
- up to 1.2.25
- What to do
- Affects up to 1.2.25. Update Fastly to the newest version and check its changelog mentions this fix; if there isn’t one yet, deactivate it until there is.
Full record and what to do →NVD recordpatchstack.compatchstack.com
Mar 6, 2023A vulnerability was found in Fastly Plugin up to 0.97 on WordPress.CVE-2015-10094 · WordPress plugins & themes · reported by VulDBLow 2.4
A vulnerability was found in Fastly Plugin up to 0.97 on WordPress. It has been rated as problematic. Affected by this issue is the function post of the file lib/api.php. The manipulation of the argument url leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.98 is able to address this issue. The patch is identified as d7fe42538f4d4af500e3af9678b6b06fba731656. It is recommended to upgrade the affected component. VDB-222326 is the identifier assigned to this vulnerability.
- Product
- Fastly
- Affected
- up to 0.97
- What to do
- Affects up to 0.97. Update Fastly to the newest version and check its changelog mentions this fix; if there isn’t one yet, deactivate it until there is.
Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.