Vulnerability database
Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.
10 results
Jul 13, 2026VW Food Corner: Missing AuthorizationCVE-2026-57774 · WordPress plugins & themes · reported by PatchstackMedium 5.3
Missing Authorization vulnerability in vowelweb VW Food Corner vw-food-corner allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects VW Food Corner: from n/a through <= 1.1.0.
- Product
- VW Food Corner
- Affected
- up to 1.1.0
- What to do
- Affects up to 1.1.0. Update VW Food Corner to the newest version and check its changelog mentions this fix; if there isn’t one yet, deactivate it until there is.
Jun 24, 2026Cornerstone: Does not enforce capability checks on one of its CSS-preview request handlersCVE-2026-9710 · WordPress plugins & themes · reported by WPScanHigh 7.7
The Cornerstone WordPress plugin before 7.8.8 does not enforce capability checks on one of its CSS-preview request handlers, and exposes the nonce needed to call it to every logged-in user on any wp-admin page, allowing any authenticated user to evaluate dynamic content tokens against arbitrary users and disclose their sensitive metadata including raw password hashes. This affects the premium co Cornerstone page builder distributed bundled with the X , not the unrelated free `cornerstone` Cornerstone WordPress plugin before 7.8.8 (v0.8.x) on the .org repository.
- Product
- Cornerstone
- Fixed in
- 7.8.8
- What to do
- Update Cornerstone to 7.8.8 or newer.
Jun 24, 2026Cornerstone: Does not enforce capability checks on one of its REST API routesCVE-2026-9709 · WordPress plugins & themes · reported by WPScanHigh 7.7
The Cornerstone WordPress plugin before 7.8.9 does not enforce capability checks on one of its REST API routes, allowing any authenticated user to disclose the metadata of any other user, including roles, session token previews and stored billing/shipping fields. This affects the premium co Cornerstone page builder distributed bundled with the X , not the unrelated free `cornerstone` Cornerstone WordPress plugin before 7.8.9 (v0.8.x) on the .org repository.
- Product
- Cornerstone
- Fixed in
- 7.8.9
- What to do
- Update Cornerstone to 7.8.9 or newer.
Jun 17, 2026Subscriber SQL Injection in Cornerstone < 7.8.8 versions.CVE-2026-54185 · WordPress plugins & themes · reported by PatchstackHigh 8.5
Subscriber SQL Injection in Cornerstone < 7.8.8 versions.
- What to do
- Update the plugin to the newest version.
Jun 17, 2026Subscriber Arbitrary Code Execution in Cornerstone < 7.8.8 versions.CVE-2026-49113 · WordPress plugins & themes · reported by PatchstackHigh 8.5
Subscriber Arbitrary Code Execution in Cornerstone < 7.8.8 versions.
- What to do
- Update the plugin to the newest version.
Dec 9, 2025Cornerstone: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2025-63072 · WordPress plugins & themes · reported by PatchstackMedium 6.5
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in THEMECO Cornerstone cornerstone allows Stored XSS.This issue affects Cornerstone: from n/a through <= 7.7.3.
- Product
- Cornerstone
- Affected
- up to 7.7.3
- What to do
- Affects up to 7.7.3. Update Cornerstone to the newest version and check its changelog mentions this fix; if there isn’t one yet, deactivate it until there is.
Apr 18, 2024Cornerstone: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-32570 · WordPress plugins & themes · reported by PatchstackHigh 7.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Archetyped Cornerstone allows Reflected XSS.This issue affects Cornerstone: from n/a through 0.8.0.
- Product
- Cornerstone
- Affected
- up to 0.8.0
- What to do
- Affects up to 0.8.0. Update Cornerstone to the newest version and check its changelog mentions this fix; if there isn’t one yet, deactivate it until there is.
Full record and what to do →NVD recordpatchstack.compatchstack.com
Mar 28, 2024Cornerstone: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-28002 · WordPress plugins & themes · reported by PatchstackHigh 7.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Archetyped Cornerstone allows Reflected XSS.This issue affects Cornerstone: from n/a through 0.8.0.
- Product
- Cornerstone
- Affected
- up to 0.8.0
- What to do
- Affects up to 0.8.0. Update Cornerstone to the newest version and check its changelog mentions this fix; if there isn’t one yet, deactivate it until there is.
Full record and what to do →NVD recordpatchstack.compatchstack.com
Dec 15, 2022Corner Ad: Cross-Site Request ForgeryCVE-2022-3427 · WordPress plugins & themes · reported by WordfenceHigh 8.8
The Corner Ad plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.0.56. This is due to missing or incorrect nonce validation on its corner_ad_settings_page function. This makes it possible for unauthenticated attackers to trigger the deletion of ads via forged request granted they can trick a site administrator into performing an action such as clicking on a link.
- Product
- Corner Ad
- Affected
- up to 1.0.56
- What to do
- Affects up to 1.0.56. Update Corner Ad to the newest version and check its changelog mentions this fix; if there isn’t one yet, deactivate it until there is.
Full record and what to do →NVD recordplugins.trac.wordpress.orgplugins.trac.wordpress.org
Aug 22, 2019The corner-ad plugin before 1.0.8 for WordPress has XSS.CVE-2017-18579 · WordPress plugins & themes · reported by MITREMedium 6.1
The corner-ad plugin before 1.0.8 for WordPress has XSS.
- Product
- corner-ad
- Fixed in
- 1.0.8
- What to do
- Update corner-ad to 1.0.8 or newer.
Full record and what to do →NVD recordwordpress.orgwordpress.org
Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.
Weekly security brief
The flaws that hit local websites, every Friday.
One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.