Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies
Updated 6 h ago

Vulnerability database

Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.

1,762exploited flaws on CISA’s list
34added in the last 30 days
344new WordPress flaws this week
390,080entries in the database

105 results · page 3 of 3

  • Apr 30, 2020LearnPress Wordpress plugin version prior and including 3.2.6.7 is vulnerable to SQL InjectionCVE-2020-6010 · WordPress plugins & themes · reported by cve@checkpoint.comHigh 8.8

    LearnPress Wordpress plugin version prior and including 3.2.6.7 is vulnerable to SQL Injection

    Affected
    up to 3.2.6.7
    What to do
    Affects up to 3.2.6.7. Update the plugin to the newest version and check its changelog mentions this fix; if there isn’t one yet, deactivate it until there is.
  • Mar 16, 2020be_teacher in class-lp-admin-ajax.php in the LearnPress plugin 3.2.6.5 and earlier for WordPress allows any registered user to assign itself the teacher role viCVE-2020-7916 · WordPress plugins & themes · reported by MITREMedium 6.5

    be_teacher in class-lp-admin-ajax.php in the LearnPress plugin 3.2.6.5 and earlier for WordPress allows any registered user to assign itself the teacher role via the wp-admin/admin-ajax.php?action=learnpress_be_teacher URI without any additional permission checks. Therefore, any user can change its role to an instructor/teacher and gain access to otherwise restricted data.

    Product
    LearnPress
    Affected
    up to 3.2.6.5
    What to do
    Affects up to 3.2.6.5. Update LearnPress to the newest version and check its changelog mentions this fix; if there isn’t one yet, deactivate it until there is.
  • Jan 9, 2019the LearnPress prior to version 3.1.0: SQL injectionCVE-2018-16175 · WordPress plugins & themes · reported by vultures@jpcert.or.jpHigh 7.2

    SQL injection vulnerability in the LearnPress prior to version 3.1.0 allows attacker with administrator rights to execute arbitrary SQL commands via unspecified vectors.

    Product
    the LearnPress prior to version 3.1.0
    Fixed in
    3.1.0
    What to do
    Update the LearnPress prior to version 3.1.0 to 3.1.0 or newer.
  • Jan 9, 2019LearnPress prior to version 3.1.0: Open redirectCVE-2018-16174 · WordPress plugins & themes · reported by vultures@jpcert.or.jpMedium 6.1

    Open redirect vulnerability in LearnPress prior to version 3.1.0 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via unspecified vectors.

    Product
    LearnPress prior to version 3.1.0
    Fixed in
    3.1.0
    What to do
    Update LearnPress prior to version 3.1.0 to 3.1.0 or newer.
  • Jan 9, 2019LearnPress prior to version 3.1.0: Cross-site scriptingCVE-2018-16173 · WordPress plugins & themes · reported by vultures@jpcert.or.jpMedium 6.1

    Cross-site scripting vulnerability in LearnPress prior to version 3.1.0 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

    Product
    LearnPress prior to version 3.1.0
    Fixed in
    3.1.0
    What to do
    Update LearnPress prior to version 3.1.0 to 3.1.0 or newer.

Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.

Weekly security brief

The flaws that hit local websites, every Friday.

One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.