Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies
Updated 7 h ago

Vulnerability database

Every flaw the U.S. government’s cybersecurity agency (CISA) has confirmed attackers are using, plus the new WordPress plugin and theme bugs published each day, sorted by what they mean for a small business. We refresh it twice a day. If you see something your website or office runs, tell us.

1,762exploited flaws on CISA’s list
34added in the last 30 days
343new WordPress flaws this week
390,080entries in the database

58 results · page 2 of 2

  • Apr 17, 2024Pytorch before version v2.2.0 was discovered to contain a use-after-free vulnerability in torch/csrc/jit/mobile/interpreter.cpp.CVE-2024-31583 · Other software · pytorchlightning · reported by MITREHigh 7.8

    Pytorch before version v2.2.0 was discovered to contain a use-after-free vulnerability in torch/csrc/jit/mobile/interpreter.cpp.

    Product
    pytorch_lightning
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Apr 17, 2024PyTorch before v2.2.0 was discovered to contain a heap buffer overflow vulnerability in the component /runtime/vararg_functions.cpp.CVE-2024-31580 · Other software · pytorch · reported by MITREMedium 4

    PyTorch before v2.2.0 was discovered to contain a heap buffer overflow vulnerability in the component /runtime/vararg_functions.cpp. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted input.

    Product
    pytorch
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Nov 21, 2023TorchServe is a tool for serving and scaling PyTorch models in production.CVE-2023-48299 · Other software · pytorch · reported by GitHubMedium 5.3

    TorchServe is a tool for serving and scaling PyTorch models in production. Starting in version 0.1.0 and prior to version 0.9.0, using the model/workflow management API, there is a chance of uploading potentially harmful archives that contain files that are extracted to any location on the filesystem that is within the process permissions. Leveraging this issue could aid third-party actors in hiding harmful code in open-source/public models, which can be downloaded from the internet, and take advantage of machines running Torchserve. The ZipSlip issue in TorchServe has been fixed by validating the paths of files contained within a zip archive before extracting them. TorchServe release 0.9.0 includes fixes to address the ZipSlip vulnerability.

    Product
    serve
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Sep 28, 2023TorchServe is a tool for serving and scaling PyTorch models in production.CVE-2023-43654 · Other software · pytorch · reported by GitHubCritical 10

    TorchServe is a tool for serving and scaling PyTorch models in production. TorchServe default configuration lacks proper input validation, enabling third parties to invoke remote HTTP download requests and write files to the disk. This issue could be taken advantage of to compromise the integrity of the system and sensitive data. This issue is present in versions 0.1.0 to 0.8.1. A user is able to load the model of their choice from any URL that they would like to use. The user of TorchServe is responsible for configuring both the allowed_urls and specifying the model URL to be used. A pull request to warn the user when the default value for allowed_urls is used has been merged in PR #2534. TorchServe release 0.8.2 includes this change. Users are advised to upgrade. There are no known workarounds for this issue.

    Product
    serve
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Nov 25, 2022In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.CVE-2022-45907 · Computers, phones & browsers · Linuxfoundation · reported by MITRECritical 9.8

    In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.

    Product
    Pytorch
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Mar 5, 2022Code Injection in GitHub repository pytorchlightning/pytorch-lightning prior to 1.6.0.CVE-2022-0845 · Other software · pytorchlightning · reported by security@huntr.devCritical 9.8

    Code Injection in GitHub repository pytorchlightning/pytorch-lightning prior to 1.6.0.

    Product
    pytorchlightning/pytorch-lightning
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Dec 23, 2021pytorch-lightning is vulnerable to Deserialization of Untrusted DataCVE-2021-4118 · Other software · pytorchlightning · reported by security@huntr.devHigh 7.8

    pytorch-lightning is vulnerable to Deserialization of Untrusted Data

    Product
    pytorchlightning/pytorch-lightning
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.
  • Dec 8, 2021Sockeye is an open-source sequence-to-sequence framework for Neural Machine Translation built on PyTorch.CVE-2021-43811 · Other software · awslabs · reported by GitHubHigh 7.8

    Sockeye is an open-source sequence-to-sequence framework for Neural Machine Translation built on PyTorch. Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files. An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally. The issue is fixed in version 2.3.24.

    Product
    sockeye
    What to do
    Apply the vendor’s update. The NVD record links to the advisory.

Where this comes from: the exploited list is CISA’s Known Exploited Vulnerabilities catalog. Everything else is the whole National Vulnerability Database, where each record is published by the team that found the bug (Wordfence, Patchstack, WPScan, the vendors themselves and others); we show who. Exploit odds are FIRST’s EPSS, updated daily. Titles and categories are ours, so check the linked record before acting on a detail. For a write-up of the big ones, see our advisories. Every vendor, and every WordPress plugin and theme with a recorded flaw, also has its own page. All of it is free to reuse as JSON, CSV or RSS.

Weekly security brief

The flaws that hit local websites, every Friday.

One short email: what got exploited this week, which WordPress plugins broke, and what to check. Unsubscribe in one click.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.