Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Plugin · yet-another-related-posts-plugin

YARPP

7 known vulnerabilities on record. Add your version above to see which ones affect you.

Is YARPP safe? The full page →

  • Nov 1, 2024YARPP: Access ControlCVE-2024-43919 · affects up to 5.30.10 · reported by PatchstackMedium 5.3

    Access Control vulnerability in YARPP YARPP allows . This issue affects YARPP: from n/a through 5.30.10.

  • Jun 19, 2024YARPP – Yet Another Related Posts: Stored Cross-Site ScriptingCVE-2023-6495 · affects up to 5.30.9 · reported by WordfenceMedium 4.4

    The YARPP – Yet Another Related Posts Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to and including 5.30.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

  • May 17, 2024YARPP: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')CVE-2022-45374 · affects up to 5.30.4 · reported by PatchstackHigh 7.7

    Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in YARPP allows PHP Local File Inclusion.This issue affects YARPP: from n/a through 5.30.4.

  • Feb 28, 2024YARPP – Yet Another Related Posts: Stored Cross-Site ScriptingCVE-2024-0602 · affects up to 5.30.9 · reported by WordfenceMedium 4.4

    The YARPP – Yet Another Related Posts Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 5.30.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

  • Aug 16, 2023YARPP: Does not validate and escape some of its shortcode attributes before using them in SQL statement/sCVE-2023-0579 · fixed in 5.30.3 · reported by WPScanHigh 8.8

    The YARPP WordPress plugin before 5.30.3 does not validate and escape some of its shortcode attributes before using them in SQL statement/s, which could allow any authenticated users, such as subscribers to perform SQL Injection attacks.

  • Jul 18, 2023YARPP: Stored Cross-Site ScriptingCVE-2023-2433 · affects up to 5.30.3 · reported by WordfenceMedium 6.4

    The YARPP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'className' parameter in versions up to, and including, 5.30.3 due to insufficient input sanitization and output escaping. This makes it possible for contributor-level attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

  • Feb 13, 2023YARPP: Does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embedCVE-2022-4471 · fixed in 5.30.3 · reported by WPScanMedium 5.4

    The YARPP WordPress plugin before 5.30.3 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.