Free tool
Is my WordPress plugin safe?
Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.
Plugin · woo-rfq-for-woocommerce
NP Quote Request for WooCommerce
2 known vulnerabilities on record. Add your version above to see which ones affect you.
Sep 23, 2026NP Quote Request for WooCommerce: Does not verify order ownership before rendering an order's detailsCVE-2026-93528 · fixed in 2.4.16 · reported by WPScanLow 3.7
The NP Quote Request for WooCommerce WordPress plugin before 2.4.16 does not verify order ownership before rendering an order's details, allowing unauthenticated attackers to view another customer's order using the order's key.
Mar 20, 2025NP Quote Request for WooCommerce: Insecure Direct Object ReferenceCVE-2024-13558 · affects up to 1.9.179 · reported by WordfenceHigh 7.5
The NP Quote Request for WooCommerce plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.9.179 due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to read the content of quote requests.
Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.
Tell us what you're building.
A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.
Not ready to talk yet? Run the free website check and see what Google sees.