Critical security advisoryCriticalFlagged by our vulnerability database: PHP2Shell is on CISA’s exploited list. Most WordPress hosting runs PHP. See if your site is affectedFlagged by our vulnerability database: PHP2Shell is being exploited. DetailsExploited: PHP2Shell. Check your site
HuttenlocherTechnologies

Free tool

Is my WordPress plugin safe?

Type a plugin or theme and the version you run, and we’ll show every known vulnerability that affects it, from the 390,007 records in our vulnerability database. The version is listed under Plugins in your WordPress dashboard.

Plugin · woo-coupon-usage

Coupon Affiliates

11 known vulnerabilities on record. Add your version above to see which ones affect you.

Is Coupon Affiliates safe? The full page →

  • Jun 15, 2026Subscriber Sensitive Data Exposure in Coupon Affiliates <= 7.8.1 versions.CVE-2026-49068 · affects up to 7.8.1 · reported by PatchstackHigh 7.5

    Subscriber Sensitive Data Exposure in Coupon Affiliates <= 7.8.1 versions.

  • Jun 15, 2026Unauthenticated Cross Site Scripting (XSS) in Coupon Affiliates <= 7.5.3 versions.CVE-2026-40770 · affects up to 7.5.3 · reported by PatchstackHigh 7.1

    Unauthenticated Cross Site Scripting (XSS) in Coupon Affiliates <= 7.5.3 versions.

  • Oct 26, 2025Coupon Affiliates: Missing AuthorizationCVE-2025-62884 · affects up to 7.2.0 · reported by PatchstackMedium 5.3

    Missing Authorization vulnerability in Elliot Sowersby / RelyWP Coupon Affiliates woo-coupon-usage allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Coupon Affiliates: from n/a through <= 7.2.0.

  • Sep 22, 2025Coupon Affiliates: Missing AuthorizationCVE-2025-59567 · affects up to 6.8.0 · reported by PatchstackMedium 5.5

    Missing Authorization vulnerability in Elliot Sowersby / RelyWP Coupon Affiliates woo-coupon-usage allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Coupon Affiliates: from n/a through <= 6.8.0.

  • Aug 20, 2025Coupon Affiliates: Missing AuthorizationCVE-2025-54025 · affects up to 6.4.0 · reported by PatchstackMedium 6.5

    Missing Authorization vulnerability in Elliot Sowersby / RelyWP Coupon Affiliates woo-coupon-usage allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Coupon Affiliates: from n/a through <= 6.4.0.

  • Jul 16, 2025Coupon Affiliates: Cross-Site Request Forgery (CSRF)CVE-2025-54022 · affects up to 6.4.0 · reported by PatchstackMedium 6.5

    Cross-Site Request Forgery (CSRF) vulnerability in Elliot Sowersby / RelyWP Coupon Affiliates woo-coupon-usage allows Cross Site Request Forgery.This issue affects Coupon Affiliates: from n/a through <= 6.4.0.

  • Apr 18, 2025Coupon Affiliates – Affiliate Plugin for WooCommerce: Reflected Cross-Site ScriptingCVE-2025-3598 · affects up to .6.3.0 · reported by WordfenceMedium 6.1

    The Coupon Affiliates – Affiliate Plugin for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the commission_summary parameter in all versions up to, and including, .6.3.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

  • Dec 13, 2024The Coupon Affiliates – Affiliate Plugin for WooCommerce: Arbitrary shortcode executionCVE-2024-12421 · affects up to 5.16.7.1 · reported by WordfenceMedium 6.5

    The The Coupon Affiliates – Affiliate Plugin for WooCommerce plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.16.7.1. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. This functionality is also vulnerable to Reflected Cross-Site Scripting. The Cross-Site Scripting was patched in version 5.16.7.1, while the arbitrary shortcode execution was patched in 5.16.7.2.

  • Mar 19, 2024Coupon Affiliates: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVE-2024-29125 · affects up to 5.12.7 · reported by PatchstackHigh 7.1

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Elliot Sowersby / RelyWP Coupon Affiliates woo-coupon-usage.This issue affects Coupon Affiliates: from n/a through <= 5.12.7.

  • Aug 14, 2023Unauth.CVE-2023-30475 · affects up to 5.4.5 · reported by PatchstackHigh 7.1

    Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Elliot Sowersby, RelyWP WooCommerce Affiliate Plugin – Coupon Affiliates plugin <= 5.4.5 versions.

  • Jun 26, 2023Unauth.CVE-2023-28992 · affects up to 5.4.3 · reported by PatchstackHigh 7.1

    Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Elliot Sowersby, RelyWP Coupon Affiliates – WooCommerce Affiliate Plugin plugin <= 5.4.3 versions.

Versions are matched against the affected ranges published with each record. A plugin can ship a fix under its own numbering, so if something looks off, check the linked record. Want the whole site checked at once? Run the free website check.

Get in touch

Tell us what you're building.

A website, your marketing, a security check, an app, or the thing you've been running out of a spreadsheet for three years. A few lines is plenty.

01The person who'll do the work writes back
02A short call, then a written plan with the price
03Nothing starts until you say yes
04Hacked or down right now? Call, and we pick up the same day
843-331-6339

Not ready to talk yet? Run the free website check and see what Google sees.

What do you need?
Build
Grow
Protect
Urgent

No newsletter, no sales sequence. Just a reply.